Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have just installed Ubuntu 11.10 on my computer, and recently applied all the latest updates. As invariably happens when I do this, YouTube videos have stopped working in Mozilla Firefox. Displaying their web page shows a black box where the video should be.

The version of Mozilla I am running is 10.0.2. Does anyone know how to get these things to work. I have consulted the answer to my previous question on the subject here but to no avail.

Does anyone know how to get these things working again?

share|improve this question
    
are you using GNASH? I've had this problem using GNASH/Firefox on Fedora –  Nate Koppenhaver Mar 9 '12 at 2:51

2 Answers 2

You will need to install flash on each browser. You can get around this for youtube videos however, by switching youtube to use html5 video.

Enable HTML5 for youtube here : http://youtube.com/html5

share|improve this answer

I have a similar issue. I could figure out these solutions. The main problem is a Javascript call – one of those that Google uses to track you your preferences.

Delete your Cookies

What worked for me (and I'm not proud of it but just worked) is to delete my session cookies (accessing YouTube without being logged into my Google account). This means that you are not going to be able to check your Gmail account or anything related to your Google account.

Use the Incognito Window

You can use the Incognito mode to watch YouTube videos (an incognito window is opened pressing Ctrl+Alt+N when using Chrome).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.