Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a program using port 1596 and i have a D-Link router and i opened port 1596 but it doesn't seem to have opened because i cant connect to it but it works locally. I put the public and private both 1596 cause i wasn't sure what to put is that the problem? I put the ip of the computer its running on as the ipaddress

share|improve this question

migrated from stackoverflow.com Feb 25 '12 at 11:40

This question came from our site for professional and enthusiast programmers.

2 Answers 2

The problem is likely a modem if you have one; if so what kind is it?

EDIT:

I am unfamiliar with that modem in particular, but some modems will not port forward despite any settings. From what I have observed this is usually the case when the modem's firmware is modified by the ISP providing it (if one is). The only way I managed to by pass this was by changing the modem from a "routed bridge" to plain "bridge".

This disables the routing capabilities and often times you will also want to turn the DHCP server off. This will leave the modem as the equivalent of a "dumb pipe" to your ISP, and will give your router a WAN ip address.

Before attempting this, make sure to write/type down what the original IP address of the modem and the address it gave out to the route. You will have to assign yourself this address again if you want to reconfigure the modem, by connecting directly to it, and giving yourself a manual DHCP address in the modem's subnet, usually something like:

192.168.100.x

then use the modem's original address to access its setup page.

I have found the Connection type (bridged/routed bridge) settings under the VC menu.

share|improve this answer
    
its a speedstream 4200, but we also have that set on dmz mode. –  user1216963 Feb 25 '12 at 4:47
    
well the thing is we have a unity asset server working just fine. witch is why im confused to what the problem is –  user1216963 Feb 25 '12 at 7:18

Windows Firewall can block the connectivity. You may need to add an exception for that port. To do a quick test, just temporarily disable the Windows Firewall and see if this helps.

share|improve this answer
    
The firewall was never turned on –  user1216963 Feb 25 '12 at 4:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.