Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a 2 year old HP Pavilion DV7 Laptop running Windows 7. Everything was working fine until a couple of days ago. The laptop just crashed while I was playing a game, when I went to boot it back up I get the message "Operating System Not Found".

I looked around online and saw people saying the hard drive probably failed. To test it I pulled it out and hooked it up to my desktop as a secondary drive. Using the primary drive (my desktop HDD) I used disk management to reformat and reinstall Windows 7 on the laptop drive.

After doing this I was able to boot up the laptop drive as the primary drive when connected to my Desktop. Assuming all was good I plugged the drive back into the laptop and imagine my dismay when "Operating System Not Found" flashes on the screen again.

Any idea what could be causing this? The hard drive is confirmed as working and I'm nervous about buying a new disk when it could be something else entirely then I have two useless laptop drives.

I will check the boot order when I get home today and confirm it didn't somehow get switched to boot from CD/USB instead of the hard disk (how could that have happened while I was using it I have no idea).

Could the BIOS somehow be damaged/corrupt? If so what's a good tool to run diagnostics/repair that?

Would it possibly help to completely delete all partitions on the drive and recreate them, then reinstall windows?

Any help would be appreciated, thanks.

share|improve this question
The bios boot order is just that, the ordered list to check for bootable devices. Its sometimes convenient to keep CD/USB in front of HD. But if you have a disk still in the optical drive that has a boot record with no OS, I supposed that could cause these symptoms.(unlikely though). On a game laptop, could the hard drive cables on the motherboard end become knocked loose? – jdh Feb 25 '12 at 15:40
I use this laptop essentially the same as a desktop, it rarely ever gets moved around. It was just sitting in the same place for over a week before it crashed. I'm not sure how the cables could have come loose but I suppose that's something to look into later - I'm trying my hardest to not have to dissect the machine to get a fix. – Justin Feb 25 '12 at 16:45
A common cause of this error is it is trying to boot from a usb device that is plugged in, first try disconnecting all usb devices and see if it will boot, if this does not cure it see my answer below. – Moab Feb 25 '12 at 16:52

First of all, good job on your troubleshooting so far.
Given what you did with the hard drive, I would say it is unlikely that the hard drive itself is the cause of your boot issue.

Partitioning shouldn't be relevant in this case. Usually the boot loader is placed at the beginning of the hard drive, and it will know where the kernel is located on the hard drive. Of course there are certain issues that could arise from incorrect partitioning and trying to boot a certain partition, but I don't think that's the case (because the problem started appearing without you re-partitioning the drive and it works just fine in your desktop).

So what else could it be?

If that message appears, usually it is displayed by your BIOS. It tries to locate a boot loader on your selected boot media, but either there is no boot media, or it has no boot loader.

The latter can't be the problem (because you tried the drive in a different machine and it boots just fine).

So your BIOS could be fixed on trying to boot from the incorrect media (which you will check when you return from work, as you said).

A while ago someone asked a question on this site (sadly I couldn't find it right now) about his laptop being unable to boot from the primary hard disk. But he was able to boot just fine from a Ubuntu CD. Then he could select "Boot from first hard disk" in the boot menu and it worked fine.

That's definitely something you could try out as well. This could help localize the issue.

share|improve this answer

Use F8 at the beginning of startup to get the Advanced Boot Options menu, then choose "Repair your Computer". once WinRE loads you will enter a password if there is one for the admin account, if there is not leave it blank and hit enter, when the list of RE tools loads, choose command prompt, once the command prompt opens type the following command and hit enter key

bootrec.exe /fixmbr

(space between exe and / )

exit command prompt and recovery environment and see if it boots now.

If it does not, reload WinRE use this command

bootrec.exe /fixboot

. enter image description here

. enter image description here

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .