Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently bought a laptop that came with Windows 7 64-bit installed. I have some older (16-bit and 32-bit) software that doesn't work with 64-bit Windows, but works just fine with 32-bit. Since I also wanted to get rid of all of the pre-installed spam, I decided to wipe the hard drive and install a fresh copy of Windows 7 32-bit. I can't get the graphics cards working.

This laptop uses switchable graphics, an Intel card and a Radeon card. I first tried installing this driver from Intel, which works for the Intel card. Of course, the Radeon card doesn't work with this driver and I need it for some of the newer games I have.

I also tried this driver. Windows's device manager will recognize the Radeon card, but it will still use the Intel card. Also, even though that package says it contains the Intel driver, the Intel card still isn't properly recognized by Windows (leaving me with a nasty 800x600 resolution). On top of that, the Catalyst Control Center won't open (saying "The Catalyst Control Center is not supported by the driver version of your enabled graphics adapter")

I tried installing HP's driver then installing Intel's driver on top of it. Device manager will then recognize both graphics cards properly. However, the laptop still uses the Intel card. The CCC still won't start (saying the same thing as before) and I can't find any of 'switching' graphics cards.

Before formatting, I could right-click the desktop and click "Configure Switchable Graphics" This option hasn't been in the context menu regardless of what driver(s) I've installed. After some research, I found out that this menu entry runs the command "cli.exe Start PowerXpressHybrid" I've tried manually running this command, but I get the same unsupported message from CCC.

So, does anyone know how I can get this working? I would like to be able to switch between the Intel and Radeon. But, if there's some way to disable the Intel and use only the Radeon, that would be fine

I dual-boot with Linux (framebuffer uses the Intel, haven't even tried getting X set up yet) Here's the output of lspci

# lspci -v | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09) (prog-if 00 [VGA controller])
01:00.0 VGA compatible controller: ATI Technologies Inc NI Seymour [AMD Radeon HD 6470M] (prog-if 00 [VGA controller])

The laptop is a HP Pavilion g6t-1d00. HP doesn't support installing anything but Windows 7 64-bit, so calling tech support isn't an option.

Thanks for any help

UPDATE: I finally got it working. After a fresh install of Windows 7, I installed the HP driver (the one linked above). Then, there's an optional Windows update I installed (don't remember the exact name, but it'll stick out). After that, graphics switching works just like it's supposed to.

Moab, thanks anyways for your help

share|improve this question
    
Strange, the HP site only has the Intel integrated graphics driver listed for that model. –  Moab Feb 25 '12 at 23:45
    
@Anonymous: You should accept his answer?! –  Phpdevpad Mar 1 '12 at 4:21

3 Answers 3

I've had a similar problem with my laptop and I've found a trick. My problem was that the original driver is very old and I wanted an updated driver. I've called the manufactor of my laptop but they refuse to update the driver. Any new driver from my graphic card didn't work because of this onboard and discrete switchable graphic card thing. I didn't care much about the switchable options but I didn't make it work. The trick is to use the old original installer and swap the graphic card driver with a recently updated driver. AMD graphic driver is only a tiny part of the huge package with CCC and so on. This works great.

share|improve this answer

As a workaround, install the HP Support Assistant, run it to see if it finds correct drivers on the HP servers.

Install HPSA, run the program and click the "Maintain" icon, then click the refresh button, see what it finds.

I would do this after a clean install of W732bit.

Note: You may need to install the Intel chipset driver first, then the graphics driver package.

share|improve this answer
    
I reinstalled Windows and installed the Support Assistant. It detects the Intel card and tries to install a driver for it, but fails without giving me any reason why –  Anonymous Feb 26 '12 at 2:07
    
It may need the Intel chipset driver installed first. –  Moab Feb 26 '12 at 3:08
    
I can't find chipset drivers anywhere for 32bit Windows. The only other drivers listed in Support Assistant are for touchpad, LAN, and card reader –  Anonymous Feb 26 '12 at 5:22
    
Which chipset is it? –  Moab Feb 26 '12 at 15:27
    
Intel HM65. I found it on their site and it's all working now –  Anonymous Feb 26 '12 at 20:12

I recently ran into this issue with a Windows 8 laptop I recently purchased from Toshiba. What solved my issue was installing the integrated Intel drivers, and then installing the Catalyst Control Center provided by AMD. It recognized my second card. After that, I restarted the laptop. Following that, I was able to right click on the desktop and select "Configure Switchable Graphics." I added all my Steam games to high performance (ATI) mode, and I haven't had a problem with it since. More than likely, you'll need to do something like this.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.