Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Windows 7 machine with two hard drives: a 1TB C: drive and 500GB J:. I had Windows XP installed on C: and Windows 7 installed on J:. I installed Windows 7 after Windows XP from an installer .exe I (legally) bought and downloaded. It, and all of my other files, are sitting on my J: drive intact.

While under my Windows 7 install, a few days ago I decided to use Priform's CCleaner and use its DriveWipe utility to wipe the C: drive. 1% into the process, I cancelled and attempted to use it again. It gives me an error saying it can't format the drive, so I poke around the Internet a bit, give up, and restart my computer.

I first get an "OS is missing" error after the computer boots past the BIOS. I downloaded and put UBCD on a bootable USB to use another drivewiping tool to completely erase the C: drive, hoping it'll take the problem with it. No luck. I try to use TestDisk to make my J: my primary active drive, but no luck. I still get the "OS is missing" error. Or sometimes it'll hang at Verifying DMI Pool. Or sometimes I'll get the "NTLDR is missing" error.

I get hold of Hiren's and put it on another bootable USB. I first I tried the Boot Windows 7 from Hard Drive option, and I get "Error 15: File Not Found". I tried the "Fix 'NTLDR is Missing'" option (I'm not quite sure why this is even showing up, since I'm trying to get into a HDD with Windows 7 installed. Probably messed up somewhere when I used TestDisk) and I get this list:

enter image description here

I'll run through the error messages I get:

  • 1st Try - Windows could not start because the following file is missing or corrupt: \system32\hal.dll

  • 2nd Try - Windows could not start because the following file is missing or corrupt: \system32\ntoskrnl.exe

  • 3rd Try - Windows could not start because of a computer disk hardware configuration problem. Could not read from the selected boot disk. Check boot path and disk hardware.

  • 4th - 8th Try - Same as #3

  • 9th Try - I/O Error accessing boot sector file multi(0)disk(0)fdisk(0)\BOOTSEC.DOS. And computer freezes.

  • 10th Try - computer restarts

Needless to say, not a single one of those works.

I then tried to open up the Windows 7 exe I have sitting on my J: from the Mini-XP OS on Hiren's, but it won't run because I'm trying to run a 64-bit file from a 32-bit exe. At least, that's the problem according to these guys: http://social.technet.microsoft.com/...-b2f54e9c7d18/

I then borrowed a 64-bit Windows Home Premium CD from a friend to get to the recovery options. But I get the error message:

This version of System Recovery Options is not compatible with the version of Windows you are trying to repair. Try using a recovery disc that is compatible with this version of Windows.

I pressed Shift + F10 to get to the Command Prompt directly. These are the exact steps I took from there (paraphrased a little):

X:\Sources>bootrec /Fixmbr
The operation completed successfully.

X:\Sources>bootrec /Fixboot
The operation completed successfully.

I restarted my computer, but it still didn't work. I unplugged the C: drive, then tried bootrec and Diskpart:

X:\Sources> bootrec.exe

X:\Sources> bootrec /RebuildBcd

Total identified Windows installations: 1

[1] \\?\GLOBALROOT\Device\HarddiskVolume1\Windows

Add installation to bootlist? Yes(Y)/No(N)/All(A):y

The requested system device cannot be found.

X:\Sources>DiskPart

DISKPART> List Disk

Disk # Status Size Free Dyn Gpt

Disk 0_Online_465GB_0B_______*

Disk 1 Online 1000MB 0B (this is Hiren's on a bootable usb)

DISKPART> Select Disk 0

Disk 0 is now the selected disk.

DISKPART> List Partition

Partition # Type Size Offset
Partition 1 System 465GB 31KB

DISKPART> Select Partition 1

Partition 1 is now the selected partition

DISKPART> Active

The selected disk is not a fixed MBR disk.
The ACTIVE command can only be used on fixed MBR disks.

DISKPART> exit

Leaving Diskpart...

X:\Sources>bootrec /Fixmbr
The operation completed successfully.

X:\Sources>bootrec /Fixboot
The operation completed successfully.

Before I go any further, is there anything I'm overlooking/doing wrong? All I care about is making the J: and Windows 7 bootable again.

SPECS:

  • Windows 7 Professional 64-Bit
  • GIGABYTE - Motherboard - Socket 775 - GA-P35-DS3R (rev. 2.1)
  • Crucial Ballistix 2048MB PC6400 DDR2 800MHz (2x2GB)
  • Intel Core 2 Duo E6700 Processor (2.6 (6GHZ) I think... not sure anymore
  • C: HDD - SAMSUNG HD103UJ (1TB, not plugged in)
  • J: HDD - WDC WD5000AKS-00V1A0 (500GB)
share|improve this question
    
Can you do a directory listing (dir) on the 500gb drive? Are there any files listed? –  Moab Feb 26 '12 at 3:15
    
Did you ever fix this? –  Hubro Jan 12 '13 at 18:25

1 Answer 1

Diagnosis: given your narrative, you (likely) wiped the bootloader (NTLDR) from the MBR (Master Boot Record) of the first hard drive (C:), making your J: drive an orphan.

Microsoft Windows XP (and 7) aren't tolerant of changes in drive partitioning or connection; resulting messages can be quite misleading. Fixing a mess like this isn't a straightforward or forgiving process; the internet is full of confusion on this subject.

One detail needed is whether your J: drive was formatted with GPT or MBR-style partitioning - MBR tools aren't for GPT.

Consider: If you apply your legal Windows 7 Professional 64-bit installer to perform a second install on your C: drive, you may be able to regain access to your J: drive files. (Generally speaking, installing a second Operating System on your C: drive MAY provide a multi-boot option that could re-enable full choice of both installations.)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.