Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have both TortoiseHg 2.3 64 bit and TortoiseGit 1.7.7 64 bit installed on Vista 64 bit.

Both TortoiseHg (ssh = "C:\Program Files\TortoiseHg\TortoisePlink.exe" -ssh -2 -C -batch entry in mercurial.ini) and TortoiseGit (GIT_SSH environment variable set to C:\Program Files\TortoiseGit\bin\TortoisePlink.exe) are configured to use PuTTy's plink (command-line interface to the PuTTY back ends) versions distributed with them.

I have Pageant (PuTTy authentification client) running and proper ssh key loaded. However any hg or git command results in error dialog titled PuTTY Fatal Error being displayed with the message:

Disconnected: No supported authentication methods available. (server sent:publickey)

At the same time using original plink.exe provided with PuTTy works.

Why doesn't TortoisePlink work?

share|improve this question
    
It seems the authors of Tortoise* used a modified plink to show you a password prompt and in the process may have made it incompatible with other methods of authentication. Could you point the configuration files to the original plink and see what happens? –  billc.cn Feb 26 '12 at 12:22
    
Setting the original plink in configuration files solves the problem but I'm curious why branded versions do not work. Especially since I remember that the one from hg used to work in the past. –  Piotr Dobrogost Feb 26 '12 at 17:01
1  
@billc.cn - TortoisePlink have only modal windows on disconnect removed –  Lazy Badger Feb 26 '12 at 21:55
    
Have you tried to remove all and any command-line parameters for Mercurial (maybe only adding -v is good idea) –  Lazy Badger Feb 26 '12 at 21:57
    
@LazyBadger What parameters do You have in mind? –  Piotr Dobrogost Feb 26 '12 at 22:12

3 Answers 3

There is a problem with 64-bit TortoiseSVN working with 32-bit pageant. Either use 32-bit TortoiseSVN (IMO there is no real need for it to be 64-bit). Unofficially, the devs only supply 32-bit binaries. A 64-bit build of PuTTY is available here.

It seems that the TortoiseSVN devs put the blame on PuTTY...

share|improve this answer

What version of Pageant are you using? This might not solve the problem, but awhile back I had issues because I was using an old version of Pageant, I think.

Might not work for you but worth a try.

share|improve this answer

You can get such cryptic error message for many reasons. If it works with original plink though, chances are that there is something wrong with TortoisePLink and Sam's answer might help.

Nevertheless, it's not (entirely) true that you need 64-bit putty with 64-bit TortoisePLink. I am happily committing over 64-bit TortoisePLink taking keys from 32-bit pageant.

You aren't listing full URL of the repository and the connection info used with putty. Perhaps there is a subtle difference that's causing one to break while the other works.

Generally, the error message is telling you that there's no match between server keys and client keys. One instance where this is likely to happen is when you use incorrect username (e.g. yourusername@bitbucket.org instead of hg@bitbucket.org).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.