Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My graphic card (Nvidia Geforce 310M) worked perfectly until today. My laptop restarted unexpectedly, and deleted my drivers. Windows 7 doesn't recognize graphic card in device manager. I tried to reinstall graphic drivers, and same problem. How to solve this problem?

share|improve this question

migrated from stackoverflow.com Feb 26 '12 at 16:30

This question came from our site for professional and enthusiast programmers.

    
Were the drivers you installed from the laptop maker? More detailed info on this may asssit. –  Dave M Feb 26 '12 at 18:47

1 Answer 1

You wrote:

My graphic card (Nvidia Geforce 310M) worked perfectly until today

So, I think it's important to understand what's happen just before this problem begin since the driver is no more recognized by Windows (it was before)...

1) The restart was caused by a BSOD I presume... Is it possible to give us the Bug Check error and source? A BSOD create a dump check file. It's possible to easily access this file with the NirSoft utility BlueScreenView http://www.nirsoft.net/utils/blue_screen_view.html

2) In the device management utility devmgmt.msc is there an error message for your graphic card (a yellow triangle). What is the error number and description?

3) Did you install another device driver or another driver just before this problem? The NirSoft's Serviwin may help you to check all drivers are installed and started in your system: http://www.nirsoft.net/utils/serviwin.html

4) have you tried to do a restore to an earlier date?

As far as I know the source of this problem may be:

  • A wrong (corrupted, obsolete, incompatible) version of your graphic card driver
  • Another driver incompatible to the graphic driver (including a malware!)
  • An hardware problem with the graphic card

What you can try: Double check the driver version from the manufacturer web site, download it and install it in safe mode with a minimum of external devices connected.

If the problem can't be reproduced, this may be another driver loaded in "normal boot"...

If the problem is still present in safe mode may be it's hardware (say at "75%") ...

Hope this help. Let us know.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.