Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've recently installed Fedora 16 on a new PC, and I'm intending to use it for developing my websites. I've set up Apache to host multiple development sites on the machine.

Right now though, I am trying to install a PHP framework (Symfony2) and I'm unable to install it on to the web server. It comes back with an error saying that it's unable to write to the cache folder on the server.

I have checked and modified the folder so that it is writeable, but still the error keeps being displayed? What am I doing wrong?

share|improve this question
1  
What are the exact permissions on this folder? What exactly is Symfony saying? –  slhck Feb 26 '12 at 18:00

1 Answer 1

up vote 2 down vote accepted

Issues like these always seem to turn out to be SELinux. I'd try disabling it temporarily and see if that fixes it: sudo setenforce 0

I personally leave SELinux off right now; I'm developing with an oracle DB in a php program, and SELinux is horrible with php-ociconnect. Oracle's recommended solution is actually to turn it off. ociconnect has a similar issue to what you are having, exept for there's no errors during install, it just fails to install. It also won't start the module with it enabled when httpd is sta Security-wise that's probably not good, but I just haven't had the time or the need to make oracle play nice with SElinux

share|improve this answer
    
SELinux annoys me at the best of times, and I've realised that I haven't turned it off like I usually do. I will do this later and report back. –  mickburkejnr Feb 28 '12 at 9:31
    
I disabled SELinux but the issue is still occuring. –  mickburkejnr Mar 2 '12 at 9:00
    
Te other thing to check that I always forget about with Apache, is to make sure the parent folders are readable to apache. –  AsherMaximum Mar 3 '12 at 17:18
    
I have tried changing the owner/user to www-data, and it still doesn't work. –  mickburkejnr Mar 5 '12 at 19:39
    
The parent folders as well? I'm not sure if they have to be r+x or just r to the apache user. They might have to be r+x. Try adding world r+x permissions all the way up to root. If that doesn't fix it, I have no idea what else to try. Check the access logs of linux, see what they say. –  AsherMaximum Mar 5 '12 at 23:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.