Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a new computer with an Asus P8Z68-V LE + Intel i2500 + 8GB of RAM.

I installed Ubuntu without any issue, but the USB3 (from the motherboard - on the back of the computer) doesn't work.

I plug a USB stick -- nothing, I plug my USB3 external drive -- nothing, when I plug them into the USB2 and everything works perfectly.

Also, I ran all updates and everything is up to date.

What am I missing?

share|improve this question
    
I'd say you're missing the driver for your motherboard's USB3 controller. What kind of controller is on that motherboard? Which version of Ubuntu? What drivers, etc. have you tried already? –  Ƭᴇcʜιᴇ007 Feb 26 '12 at 19:31
    
i just got the computer with ubuntu 10.10 0 tried 11.10 same result. no idea what kind of controller z68? –  Adéline Feb 26 '12 at 19:34
    
Perhaps check out Asus' web site for info/specs on the controller and maybe even drivers, and update your question with pertinent info. –  Ƭᴇcʜιᴇ007 Feb 26 '12 at 19:38
    
they dont have anything i cant find about ubuntu :( –  Adéline Feb 26 '12 at 19:41
    
You probably won't find anything Unbuntu specific. You may find that you have to build some generic Linux drivers up from their source, instead of some easy ready made package. Google your MoBo version with linux as a keyword, hopefully with some searching you'll get there! –  Amicable Mar 1 '12 at 12:19

2 Answers 2

12.04 should be released any day. I would try that before building a custom kernel. I have an add-in USB card with a NEC controller that works with 11.10. My lspci -nn for that card looks like this

02:00.0 USB Controller [0c03]: NEC Corporation uPD720200 USB 3.0 Host Controller [1033:0194] (rev 03)

The driver module is xhci_hcd

$ ls -l /sys/bus/pci/devices/0000\:02\:00.0/driver
lrwxrwxrwx 1 root root 0 2012-04-24 17:31 /sys/bus/pci/devices/0000:02:00.0/driver -> ../../../../bus/pci/drivers/xhci_hcd

It is not impossible that the only thing that is needed is a mapping from your pci id to driver, and the kernel developers are usually quick to add that. Then it might take some time to get into the released distributions.

share|improve this answer

Yes, it's a hardware problem. I'm having the same problem on the same type board (Asus p8z77-i) I'm currently building, and I know why; USB 3 won't work on anything but Windows 7 and up (the manual will tell you this in another way as well). It's not the fault of ASUS, it's most motherboards at this point. Look up Linux compatible USB 3 cards because it's worth it (this is true of PCI-E cards for USB 3 functions as well. On New Egg, I found 4 usable cards and 2 were sold out (which should tell you how in demand non-windows USB 3 cards are for us).

But they're less then 40 dollars and USB 3 is 5x faster so it'll save you alot of wait time and frustration. I hope this helps!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.