Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The problem is that in full screen mode, the screen updates only when i click my mouse (as if other events such as moving my mouse or typing on the keyboard do not trigger a screen update). One strange thing is that I was able to get it to work properly before (with some switching between different view modes in VirtualBox).

I am running Ubuntu 11.10 (guest) on VirtualBox 4.1.8 on Win7.

share|improve this question
add comment

3 Answers

up vote 1 down vote accepted

(After some days of searching) I found the solution: https://www.virtualbox.org/ticket/6089

the problem is due to the handling of 3D acceleration and compiz. So disabling either will solve the problem. I found switching to Ubuntu 2D at login screen the easiest way to fix it.

share|improve this answer
add comment

I'm having the same issue with any animations not working when in full screen mode with 3D enabled. I'm running the latest Virtualbox 4.1.18 on a Windows 7 x64 host and Ubuntu 12.04 guest.

I solved the problem by disabling the 3D Acceleration in the VirtualBox settings. However, this slightly damages the user experience since features like snapping windows are no longer available. Grabbing the edge of a window to re-size also becomes quite difficult.

share|improve this answer
add comment

I have experienced with similar issue and have solved it increasing video memory size (Virtual Machine Settings | Display | Video | Video Memory). It seems by default Virtual Box set invalid (too low) size.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.