Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Ever since I upgraded to Snow Leopard on my Mac, it insists on showing me the soft keyboard when it asks for a password.

It wouldn't be too bad if it dissappeared afterward, but no. It stays there taking half my screen real estate.

I can't seem to find anything in preferences, I have looked under keyboards, security, universal access.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

In the System Preferences » Language & Text » Input Sources search for any language that is enabled but still seems deactivated (grayed out). Deselect and select to fix that. You may also need to ensure U.S. is selected.

share|improve this answer
    
This does nothing regarding the Keyboard Viewer. Even if the checkbox is deselected the keyboard appears on screen when a password is required or an AppleScript is run that has a shortcut assigned. –  Rafael Feb 29 '12 at 10:33
    
Too bad it didn't work for you, @Rafael, but it surely did for me a long time ago. And given the "accepted" answer I assume it worked for the OP too. Did you see any active-but-non-selected language in that list on your Mac? And did enabling U.S. change anything? (I currently have US, Dutch and Unicode activated, but am no longer on Snow Leopard though.) –  Arjan Feb 29 '12 at 22:30
    
Thanks for the follow-up, but your suggestions didn’t change anything. I instead restarted the Mac and the Keyboard Viewer stop to automatically appear. –  Rafael Mar 7 '12 at 15:02

Take a look under Language & Text -> Input Sources -> Keyboard and Character Viewer.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.