Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've installed VirtualBox 4.1.8 on a Windows 7 Ultimate host system. I've set up an Arch Linux VM that starts just fine from the VirtualBox GUI. However, when I try to start it with VBoxHeadless --startvm <vm_name> it prints the following

Oracle VM VirtualBox Headless Interface 4.1.6
(C) 2008-2011 Oracle Corporation
All rights reserved.

and then it just sits there. I never get the VRDE server is listening on port 3389 message like when I start a headless VM on a Linux machine.

Do I have to configure anything else in order to get the VRDE server to run?

share|improve this question

2 Answers 2

Sounds like the extension pack is installed, the message means the RDP server is running and that means it is waiting for a connection.

You just need to use MSTSC.exe to connect: hit WindowsKey+R to open a 'Run' dialog and then type MSTSC.exe 1.2.3.4:1234 (where the numbers are your guest's IP address and port number (after the ':').

Assuming you haven't changed the default port (3389) then the IP address will probably be 127.0.0.2 from the host machine. Check this works first. If this works from the host machine then you can either use port forwarding with NAT or bridged adapter mode to connect from a different machine (both have Pros/Cons - Google it).

Good luck!

share|improve this answer

You need to install the "VM VirtualBox Extension Pack" (for the version of the VirtualBox you have installed) in order to get the VRDE support.

For the guest machine(s) you should activate it and you may also change the port if you check under "settings", "Screen" and then "Remote desktop" that the server is activated.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.