Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

According to the Google Chrome Blog for Thursday, January 5, 2012, Chrome had added a beta feature where it sometimes loads a web page in the background before you finish typing the URL. When you do finish and press enter, it can just display it. I can confirm that as of version 17, this feature is in the stable release.

How can I turn off this prefetching?

Why

I am a developer, and this feature just caused me some confusion; it appeared that one of my web apps was doing a "double redirect", but the actual cause was that Chrome requested the page once while I was typing the URL and again when I pressed enter. (This behavior is not totally consistent, either.)

What I've tried

I have searched for "prediction" in preferences and unchecked the following:

  • "Use a prediction service to help complete searches and URLs typed in the address bar"
  • "Predict network actions to improve page load performance", but the problem persists (at least for loading sites hosted on my own machine).
share|improve this question
1  
According to Making web pages load faster (prerendering) - Google Chrome Help, disabling Predict network actions to improve page load performance should have done the trick. Did you restart your browser afterwards? –  Dennis Feb 27 '12 at 15:36
    
@Dennis - Yes, I did quit the browser and open it again. –  Nathan Long Feb 27 '12 at 15:42
add comment

2 Answers 2

up vote 12 down vote accepted

To turn off prerendering completely, disable the following:

  • Predict network actions to improve page load performance

    chrome://settings/advanced

    under the hood


  • Prerender from omnibox

    chrome://flags/

    flags

share|improve this answer
2  
was the omnibox option renamed/moved? I think now the only setting that controls both is the predict network actions one. –  eglasius Aug 21 '12 at 12:37
add comment

Yes, you can. The google developer whitepaper on prerendering, in the "Debugging prerendering" section, says:

You also have the option of disabling the Chrome 17+ feature that can initiate prerendering based on user interaction with the address bar. To disable this type of prerendering, start Chrome with a command-line flag of --prerender-from-omnibox=disabled.

Read the whole section/whitepaper. It's full of good stuff.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.