Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am aware of this very similar question:

But I have tried with 3 different mouses and everyone of them exibit the same behavior. Simple enough, 1 out of 3 times I get a double click when single clicking).

I searched the net a lot about this problem and have yet to find a solution.

I have tried:

  1. switch to another mouse

  2. uninstall the mouse drivers + reboot

  3. I do not have any special mouse drivers/software like intellisense and logitecs to uninstall.

  4. verified that I was not in fact on some setting that says open files with single click.

  5. everything is up to date including a antivirus

  6. Installed fresh drivers from dell's website

It is a dell vostro 260 computer running windows 7 pro 64. edit: added a 6th thing I tried. edit2: tried reinstalling every windows update I could find nothing Boss just said he'd buy me a logitech mouse hoping the drivers will fix my problems. Hopefuly!

share|improve this question
1  
Do you have another computer you can test these mice on? When you say everything is up to date, does that include drivers for other system hardware, such as USB and mainboard? Otherwise, you've done very well to describe the issue, show how it differs from the similar question, and describe your already-completed troubleshooting steps. Well done. +1 –  music2myear Feb 27 '12 at 16:11
    
As far as I know everything is up to date. As in all the computer and windows itself. I have not tried my mouses on another computer I'll try to do that. –  Iznogood Feb 27 '12 at 16:12
    
Out of curiosity, what are you clicking? Does it happen to only certain items; i.e. shortcuts, documents, hyperlinks? –  CharlieRB Feb 27 '12 at 16:21
    
@CharlieRB EVERYTHING. I am a programmer and have to click a lot. It happens in my editor (will select a word instead of placing cursor) in filezilla, in exporer, on my desktop, everywhere. –  Iznogood Feb 27 '12 at 16:22
    
I had the same issue for over a year, turns out it was a flaky mouse, I could unplug the mouse for a few weeks and use another one, then go back to the original mouse it would work for month or 3 and start its phantom double clicks eventually, finally it does if for any PC I plug it into, so my problem was a defective (dying) mouse in the end. Not sure if this helps you or not. –  Moab Feb 27 '12 at 17:49

3 Answers 3

Answering myself since this is what fixed it in the end. So in the end buying a new logitech mouse and installing its drivers seems to have fixed the issue. At least for now. Thanks for everyone who tried to help.

share|improve this answer

With all the steps you've described and a few assumptions ("everything up to date" includes drivers, the mice themselves are known-good and work OK on other computers), the only remaining significant possibilities are:

  1. The USB connections: Make sure you tried the different mice on different USB connections. If there are PS2 connectors and you have a PS2 mouse to try and it works there, the problem is probably with USB on the computer.

  2. The OS: Try reinstalling the latest service pack or running a repair of the OS (you'll need the OS disk to do this) or a System File Check (in Command prompt run as Administrator type sfc /scannow to have the OS check all critical system files).

share|improve this answer
    
Thanks for the input! But it did not help. I edited my question my boss is buying me a new mouse perhaps its drivers (logitech's) will help. –  Iznogood Feb 27 '12 at 16:56
    
Were the mice you tried all the same model? –  music2myear Feb 28 '12 at 14:25
    
nope. One dell and one generic. –  Iznogood Feb 28 '12 at 15:07
    
Ok. Then I'm not sure getting a different mouse would do the trick. But, it's a cheap and easy possible fix, and it's always best to try those before the complex or expensive fixes, such as reformatting the computer or replacing the mainboard. –  music2myear Feb 28 '12 at 15:17
    
Yeah well if you look at the answer I posted I indeed got a new mouse and it did fix the issue. No idea if it was a driver problem or what. But it works! –  Iznogood Feb 28 '12 at 15:43

I figured out that switching the left click with right click was not causing the problem of file opening at single click (Control Panel → Devices and Printers → Mouse → Mouse Settings → Button Settings → switching primary and secondary buttons.

There was a defect in the left click of the mouse.

I changed the mouse (both are from HP – same make). Now everything is fine. So, it was the left click button of the mouse that was defective and causing the problem. Change the mouse with a new one.

share|improve this answer
1  
He did –  Oliver Salzburg Jun 3 '12 at 10:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.