Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have been struggling with this issue now for a week. Here's the basics behind things... First of all, the main firewall/DHCP Server/et al for my workplace is a SnapGear SG850. Until recently, everything's been working fine and dandy.

Recently, however, the following problem has arisen.

When going Add a Device or Add a Printer on a Windows 7 machine, or when going into the network to search for a specific computer to attach to (for instance, when looking for another computer to connect to their shared computer), the Windows 7 machine INSTANTLY loses all network connectivity. It retains the assigned IP and whatnot, but you can no longer ping the gateway, DHCP servers, or anything else on the network in any way, shape or form.

The ONLY solution I've found to fix this so far is to log in (from another computer) to the SnapGear SG850 and reboot the router (or, conversely, walk up to it and unplug it). However, this then takes down all the other computers at the same time, resulting in one happy person and 55 unhappy people.

This does NOT occur with a windows XP or earlier machine. While on an XP machine, I'm able to connect to the network neighborhood, surf to any computer on the network (including a win7 machine) and connect to their shared files/printers without any issue at all.

Thoughts? Any help is massively appreciated!

share|improve this question
    
A few other things I have tried. I have flushed the DNS. I have tried completely uninstalling the lan card entirely and letting the Win7 computer reinstall it after a reboot. Neither has worked. –  Matt Feb 27 '12 at 16:15
    
Hrm... this is an interesting point. Thinking it might have been one of the latest Windows updates, I pulled a spare Win7 laptop out of the closet (has not been turned on in 3 months). Same issue... however, when I logged into the SG850 and simply deleted the IP of the now borked computer out of the DHCP listing and did an ipconfig release/renew... it now has connectivity again. Mind you, the moment I tried to look at the network neighborhood again, I lost all connectivity again. But that's more info I didn't have before. –  Matt Feb 27 '12 at 16:37
    
Found a very annoying workaround. I start the process on the win7 machine, getting to the screen where it's displaying computers on the network. When it loses connection, I log into the DHCP server and delete the SPECIFIC Ip out of the DHCP table listing. Then I do a ipconfic release/renew, and the computer is assigned a new (and working) IP at this point. This isn't a very convenient method, mind you, so any help getting past this is very appreciated... going to 50+ computers and resetting each and every one isn't exactly something I'd look forward to doing. –  Matt Feb 27 '12 at 17:28
    
Well, I did finally figure out what was going on, and I'll post it here even though no one ever responded to me... but this might help someone down the road, so here goes. Basically, the problem WAS in my firewall. Specifically in the Intrusion Detection section. Detect TCP probes Block sites probing TCP ports Detect UDP probes Block sites probing UDP ports These four were checked, and every time a machine would search for another machine on the LAN, its IP would show up on the "blocked" listing. I simply added the internal Lan IP range to the "addresses to ignore" box. –  Matt May 11 '12 at 19:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.