Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Ubuntu 10.04, connecting to a Windows 2008 box. I've got rdesktop configured to use RDPv5 (using RDPv4 is known to cause clipboard issues).

The clipboard has worked just fine for most of the time that I've been using rdesktop (I've had the machine installed for a year and a half or so). The other day, I was running a different remote access client (proprietary solution called Bomgar). Something FUBARed (I can't give an exact description of what happened, since I wasn't paying enough attention at the time). When I went to paste something on to the Win2008 client, I just got the last item in the Windows copy and paste buffer, not the item from my primary clipboard on Ubuntu.

At the time, I was also running Synergy on the Ubuntu box, sharing mouse, keyboard and clipboard with a MacBook Pro. I've since rebooted the Linux box, and haven't re-started Bomgar or Synergy, but I still don't have clipboard support.

Here's the command line as I pulled it out of ps aux:

rdesktop -ubartonski -pXXXXXXXXXX -dNTDOMAIN -ncribbage -g1400x1050 -rsound:local -rclipboard:PRIMARYCLIPBOARD -5 win2k8.prod.mycompany.com

Note the flags -rclipboard:PRIMARYCLIPBOARD and -5 (I.e. I am using RDPv5. Terminal Server Client isn't lying to me).

I checked was to make sure that things weren't getting stuck in the secondary clipboard buffer for some reason on the Linux side. I tried pasting from all three buffers, none of them worked.

share|improve this question
add comment

1 Answer

up vote 4 down vote accepted

Logging out of Windows2008 then logging back in solved the problem.

... it's always the simple stuff ...

share|improve this answer
    
Worked for me to with Win7 –  olore Aug 22 '13 at 11:52
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.