Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I would like to set up my Cisco 877w router with two SSIDs, WPA (currently working in my config) and WEP.

I have dumped my current config at the end of this question which is fully working for WPA.

My aim is to have:

  • Another SSID (AIBONET) with WEP authentication
  • The two networks having exactly the same access

My configuration

Current configuration : 3995 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CISCO877
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
enable secret 5 xyz.
!
aaa new-model
!
aaa session-id common
!
crypto pki trustpoint TP-self-signed-240059495
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-240059495
 revocation-check none
 rsakeypair TP-self-signed-240059495
!
!
dot11 syslog
!
dot11 ssid CISCO877
   authentication open
   authentication key-management wpa
   guest-mode
   wpa-psk ascii 0 1234567890
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 10.2.1.0 10.2.1.10
ip dhcp excluded-address 10.2.1.200 10.2.1.254
!
ip dhcp pool lanpool
   network 10.2.1.0 255.255.255.0
   dns-server xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx
   default-router 10.2.1.1
   lease 0 2
!
!
no ip domain lookup
ip domain name my.domain.com
ip name-server xxx.xxx.xxx.xxx
ip name-server xxx.xxx.xxx.xxx
!
!
!
username nick privilege 15 secret 5 xyz
!
!
archive
 log config
  hidekeys
!
!
ip ssh version 2
!
bridge irb
!
!
interface ATM0
 mac-address 1111.2222.3333
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 no atm ilmi-keepalive
 dsl operating-mode adsl2+
!
interface ATM0.1 point-to-point
 description BE Broadband
 ip address xxx.xxx.xxx.xxx 255.255.252.0
 ip nat outside
 ip virtual-reassembly
 atm route-bridged ip
 pvc 0/101
  oam-pvc manage
  encapsulation aal5snap
 !
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Dot11Radio0
 description WIRELESS INTERFACE
 no ip address
 !
 encryption mode ciphers tkip
 !
 encryption vlan 1 mode ciphers tkip
 !
 ssid CISCO877
 !
 speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
 station-role root
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 spanning-disabled
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
!
interface Vlan1
 description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$
 no ip address
 ip tcp adjust-mss 1452
 bridge-group 1
!
interface BVI1
 description Local Network
 ip address 10.2.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 xxx.xxx.xxx.xxx
!
no ip http server
no ip http secure-server
ip nat inside source static tcp 10.2.1.1 22 interface ATM0 22
ip nat inside source list 111 interface ATM0.1 overload
ip nat inside source static tcp 10.2.1.81 9000 interface ATM0.1 9000
ip nat inside source static tcp 10.2.1.81 3389 interface ATM0.1 3389
ip nat inside source static tcp 10.2.1.81 8182 interface ATM0.1 8182
ip nat inside source static tcp 10.2.1.81 80 interface ATM0.1 80
ip nat inside source static tcp 10.2.1.81 443 interface ATM0.1 443
!
access-list 1 permit any
access-list 99 permit 10.2.1.0 0.0.0.255
access-list 99 remark SSH Allowed Hosts
access-list 110 remark MYVPN TO REMOTEVPN
access-list 110 permit ip 10.2.1.0 0.0.0.255 192.168.13.0 0.0.0.255
access-list 111 deny   ip 10.2.1.0 0.0.0.255 192.168.13.0 0.0.0.255
access-list 111 permit ip 10.2.1.0 0.0.0.255 any
no cdp run
!
!
!
control-plane
!
bridge 1 protocol ieee
bridge 1 route ip
banner exec ^C
!
line con 0
 no modem enable
 transport output telnet
line aux 0
 transport output telnet
line vty 0 4
 access-class 99 in
 privilege level 15
 transport input ssh
 transport output none
!
scheduler max-task-time 5000
scheduler allocate 4000 1000
scheduler interval 500
end

I have consulted the documentation on the advice of wizlog here but my lack of experience is preventing me from implementing this with my current config.

share|improve this question
    
I'll take a look –  wizlog Feb 28 '12 at 3:14
    
@wizlog Thanks for this. –  Nick Feb 28 '12 at 8:16

2 Answers 2

You're going to have to configure multiple SSIDs and assign them to different VLANs. 1 SSID will be configured for WPA and the other for open authentication. Then you will have to configure WEP on that WEP VLAN.

http://www.cisco.com/en/US/docs/wireless/access_point/12.2_13_JA/configuration/guide/s13auth.html#wp1035522

http://www.cisco.com/en/US/docs/wireless/access_point/12.2_13_JA/configuration/guide/s13wep.html#wpxref84380

share|improve this answer

Check Chapter 9 (Configuring a Wireless LAN Connection) of the Cisco Configuration Guide for detailed instructions on how to configure your router.

Step 6 (9-3) and be sure to check their example.

share|improve this answer
    
Thanks so much for providing this resource. I've just been experimenting with this for the last 30 minutes or so and can't seem to make it fit my configuration. If it's appropriate and you don't mind, could I show you my configu for any advice you may be able to give? Thanks. –  Nick Feb 27 '12 at 22:07
    
@Nick I'm glad to give my advice, and even happier when its received well. Please post your config so I can better understand you problem, and so that I can better assist you. –  wizlog Feb 28 '12 at 0:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.