Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am a web developer and I'm trying to establish a workflow between OSX Lion ( Design + Development ), Parallels + Ubuntu preproduction server.

I am trying to create a connection to share files ( images, js, css, etc... ) in a fast way, but I cannot achieve to create a NFS connection.

NOTE: You can share folders in Parallels, but due to later problems with GIT and SVN ( doesn't follow symlinks ) I need to find an alternative.

OK, that said:

I have to machines:

VM Ubuntu Server: Client:

Ubuntu server conf:


(Not really sure how masks are working)


I executed:

sudo exportfs -ra
sudo /etc/init.d/portmap restart
sudo /etc/init.d/nfs-kernel-server restart
sudo /etc/init.d/nfs-common <- This is command not found althought I installed it using aptitude

Finally this is what I execute on Lion: sudo mount -t nfs -o resvport,vers=4 /home with the answer "mount_nfs: can't mount /nfs from onto /home: Permission denied"

I also tried via Finder ( Command-K - Network Connection ) and via Disk Utility ( NFS Connection, this last one says the connection is ok, but the only thing it does is to hide the local folder until the connection is removed again... )

I tried commands like:

showmount -e

showmount: Cannot retrieve info from host: RPC: Program not registered


rpcinfo -p

No remote programs registered.

I thing I pretty much gave you all the information I got.


share|improve this question

1 Answer 1

Ok I found the solution, this is my current configuration:

VM Ubuntu Server: 
From OSX Lion:

From VM Ubuntu Server


sudo vi /etc/exports
/path/to/folder *(rw,sync,subtree_check,insecure)

Hosts allow

sudo vi /etc/hosts.allow

Hosts deny

sudo vi /etc/hosts.deny

Restart servers:

chown nobody:nogroup /path/to/folder
exportfs -a
sudo /etc/init.d/nfs-kernel-server restart
sudo /etc/init.d/portmap restart

Finally from OSX Lion

sudo mount -t nfs /local/folder/

Hope it helps someone else!

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.