Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My Drobo FS has a few shares. I mount them on my Ubuntu 11.10 64 bit machine with no problem and can write and read those shares. When I run Banshee (2.2.1) in order to rip CDs into my Drobo, it fails with permission error when trying to create the directory.

When looking at the Banshee process it runs with my credentials (ps | grep banshee) so what am I missing?

share|improve this question
    
tried to add the tag "drobo-fs" but cant due to low reputation. Who/Where do I suggest this tag to? –  DrorCohen Feb 28 '12 at 8:30
1  
I added it for you – it seems reasonable enough that someone would use it in the future. –  slhck Feb 28 '12 at 8:44

1 Answer 1

up vote 0 down vote accepted

Ok, found out what I was missing... mount point was mounted as root - didn't use the uid, gid options... and I could create files only from Windows...

so for the next puzzled guy here's what you need to put in your fstab file:

//your-server-name/path /your-mount-point    cifs   username=serveruser,password=serverpassword,_netdev,uid=clientuser,gid=clientgroup     0       0

Hope this helps someone...

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.