Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a PC where the desktop background options are disabled. I have tried resetting the ActiveDesktop - AllowChangingWallpaper (something like that) to no avail. There is no security enabled on the machine, it is running BitDefender after a recent trojan attack. That is all I know at the moment, but nowhere can I find any way to enable the background options.

Machine is running XP Home.

share|improve this question
add comment

4 Answers 4

up vote 0 down vote accepted

Microsoft has a Support Article on this problem here. There is 4 keys needed in the registry to enable/disable this functionality:

  • NoDispCPL
  • NoDispBackgroundPage
  • NoDispScrSavPage
  • NoDispSettingsPage

There is also two different registry keys that are affected:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\System

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System

share|improve this answer
    
Also NoDispAppearance. –  ProfK Sep 17 '09 at 7:23
add comment

Go to Start - Run and start "gpedit.msc" (the Global Policy Editor).

Go to User Configuration - Administrative Templates - Control Panel - Display. Check the configuration of the items "Prevent changing wallpaper" and the 4 "Hide..." ones.

They should be set to "Not configured" or "Disabled".

share|improve this answer
    
gpedit.msc isn't found. –  ProfK Sep 11 '09 at 6:52
    
That is, when I try run it, I get the 'Isn't a command' error. –  ProfK Sep 11 '09 at 6:53
    
Strange, unless the Trojan messed up your Windows XP. gpedit.msc should be in \Windows\System32. From Start-Run, open mmc.exe. Go to File-Open and select gpedit.msc in \Windows\System32. –  Snark Sep 11 '09 at 7:42
    
If it's XP Home, it won't have it –  Polsy Sep 11 '09 at 7:52
    
Hmm, @Polsy, if it's XP Home, surely there isn't a means of disabling the desktop background options? –  ProfK Sep 11 '09 at 12:32
show 2 more comments

The active desktop options are available by right clicking the desktop, choosing properties (which brings up a Display Properties window), Desktop tab(you can set background color/image here), Customize Desktop... button, Web tab(I believe this is active desktop). If you could be more specific about "are disabled", is Customize Desktop button disabled/non existant ?

share|improve this answer
    
No, the customize button is present, but I'm not trying to customize active desktop. As I said, the options on the same tab as the button, i.e. for choosing a background, are disabled. –  ProfK Sep 11 '09 at 6:53
add comment

Go to: http://www.kellys-korner-xp.com/xp%5Ftweaks.htm

Look to the right of #128 and see if thats the fix you are looking for.

By the way, there is also a fix to Restore Admin Tools (.msc) # 54

share|improve this answer
    
I see the #128 contains the reg value 'HKCU\....\\ActiveDesktop] "NoChangingWallPaper"=dword:00000000', which I already did, but I'll try the whole package, thanks. –  ProfK Sep 11 '09 at 14:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.