Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The system clock of my PC (not a laptop) runs behind. What could be the cause?

share|improve this question
    
As alex said in the top answer, "consider marking the answer as accepted if you thought it was helpful. It benefits all of us :)" –  David Pearce Sep 11 '09 at 8:48
    
Not really an answer but make use of ntp servers, there's a setting in Windows called "Sync time with internet servers". Use that and you time will always be accurate. –  vava Sep 11 '09 at 12:49
add comment

5 Answers

up vote 15 down vote accepted

Your CMOS battery that maintains the BIOS (and clock) information could have run out. Change it, it is usually a CR2032 battery and really easy to swap out on your motherboard.

alt text

share|improve this answer
    
This indeed did the trick. I looked at my motherboard's manual, where I found the type of the battery needed. And indeed, it was a common battery type (CR2032 like you said). Again, thanks for solving my problem. –  Dimitri C. Sep 12 '09 at 21:26
add comment

Another potential cause not listed here is the RTC crystal is failing or not behaving.

alt text

share|improve this answer
add comment

CMOS battery, bug in the OS, I have seen it under systems with a heavy load losing time. Possible when you run down the battery and it goes to sleep or hibernation you lose time. If it's a new laptop I wouldn't worry about the CMOS battery, just use NTP.

share|improve this answer
    
Specifically use ntp.org (or one of the country/regional sub-domains). Most OSs will query on a regular interval to keep things correct. –  Richard Sep 11 '09 at 8:55
add comment

possibly a weak cmos backup battery?

share|improve this answer
    
Is that on the motherboard? Do you think this can be replaced? –  Dimitri C. Sep 11 '09 at 6:59
    
yes and easily - someone seems to have answered with a picture of it as well :) –  Journeyman Geek Sep 11 '09 at 7:50
add comment

Check your reginal settings (double click on the clock in the taskbar). You may need to check if the daylight savings box is correct and that your laptop believes it is in the correct timzone.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.