Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In Google Chrome, one can select a piece of text on a web page, right click and select "Search with Bing" (Or whatever search engine one has set as the default)
However, I'm having trouble getting Chrome to use my preferred locale for Bing.

I have my English Windows 7 location set to Switzerland, but I have set my Bing preferences to use the U.S. version of Bing. So when I simply browse to http://bing.com I end up on the U.S. Bing, just the way I want.

But when I select a piece of text, right click and do Search with Bing, it uses the Swiss Bing.
I have even set my custom search engine in Chrome to be the US Bing by setting it to:
http://www.bing.com/?scope=web&setmkt=en-us
but I still end up in
http://www.bing.com/search?setmkt=fr-CH
(which even doesn't make sense, since I'm in the de-CH part of Switzerland.

Anyone have any ideas? How can I force Chrome to use the U.S. Bing?

share|improve this question
    
As an experiment change the location to US, see if it works now. –  Moab Feb 28 '12 at 20:35
    
Have changed the location to US, still bringing up French-Swiss Bing. –  Magnus Mar 2 '12 at 20:08
    
Which OS? maybe your DNS cache needs clearing. –  Moab Mar 4 '12 at 0:41

2 Answers 2

From within Chrome select Options - Search - Manage Search Options to select the engine you wish to use.

share|improve this answer
    
That is exactly what I have done already without success. I will clarify my question. –  Magnus Feb 28 '12 at 19:58
up vote 0 down vote accepted

Hmm.. I removed the Bing entry I had and added a new one:
http://www.bing.com/search?setmkt=en-US&q=%s

And now it seems to work fine.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.