Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an eSATA docking station like the one in this picture:

                                                  enter image description here

Every now and then, when I try to eject my drive, Windows complains with the following message:

                  enter image description here

Things I tried:

  1. I followed the instructions in this thread: Can Windows tell me what is using my USB drive? and I have Sysinternals Process Explorer installed, but when I search for the drive letter (F:\ in my case) nothing pops up.

  2. Following Oliver Salzburg's suggestion I run mountvol on cmd and got the unique drive identifier that widnows reports is associated with F:\. I then searched for any handles referring to this identifier in Sysinternals Process Explorer but again nothing popped up.

  3. Following Alan's suggestion I tried Sysinternals handle, ahd this is what I got:

Handle v3.46 Copyright (C) 1997-2011 Mark Russinovich Sysinternals -

svchost.exe pid: 1020 type: File 594: F:

svchost.exe pid: 1020 type: File 5C4: F:\$Extend\$ObjId

svchost.exe pid: 1020 type: File 604: F:\System Volume Information\tracking.log

I can see that svchost is blocking my process, which technically answers my question. Now, would anybody mind helping me figure out how, knowing this, I can unblock the device?

share|improve this question
Maybe it's not being accessed through the drive letter, but through the unique device identifier. Use mountvol to determine it. – Oliver Salzburg Feb 29 '12 at 14:22
eSATA is not USB also. – EBGreen Feb 29 '12 at 15:32
Try Handle -c 1020 – EBGreen Feb 29 '12 at 16:21
Using Process Explorer you can easily determine what services are run by that service host by simply hovering with your mouse over the process with that PID (1020). – Oliver Salzburg Feb 29 '12 at 16:30
up vote 2 down vote accepted

Try the command line Handle utility, also from SysInternals.

At the prompt, issue:

handle f:
share|improve this answer

Make sure to use "Run as administrator" when running Process Explorer. This will allow it to show additional things (like System and svchost.exe) that have open handles to the drive.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .