Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The "Code" group on my Developer tab in PowerPoint 2010 is entirely disabled. For clarity, the "Visual Basic", "Macros", and "Macro Security" buttons are greyed/grayed out. I am also unable to open VB Editor via Alt+F11. Note that these options (including VB Editor) are available in Excel and Outlook of the same install.

I have reinstalled Office 2010, ensuring that Shared Tools are selected, with no success. I have searched through the registry for any obvious keys that might be responsible for this and found nothing. I have also searched for quite a while on other sites and came up with no answers.

Can you help? Is there a policy or registry key that might be disabling these functions?

share|improve this question
    
Check the trust center - file - options - trust center - trust center settings - disable all macros with notification and it will notify you to enable macros on projects where you want them. –  Raystafarian Feb 29 '12 at 15:30
    
Unfortunately, that isn't the problem. That setting is already set to that effect. Visual Basic itself is completely inaccessible in the program. –  variant Feb 29 '12 at 15:38
    
Have you tried setting it to 'enabled', maybe the prompt isn't displaying. Does this happen on all presentations or only certain ones? –  Raystafarian Feb 29 '12 at 15:41
    
It's not about enabling macros - the entire VB feature set is absent in PowerPoint. So no presentations can be edited from a coding perspective. –  variant Feb 29 '12 at 17:18

1 Answer 1

up vote 1 down vote accepted

Found the, er, problem. It was a policy setting under HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\14.0\powerpoint

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.