Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am dual-booting Fedora 16 and Windows 7, and using grub to handle booting. The default is set to Fedora, and I have a real problem with getting distracted during boot and having it boot into Fedora when I want to go to windows. I would like it to, instead of timing out and booting to the default, to just sit in GRUB until I choose one. How can I make it do that?

share|improve this question
up vote 3 down vote accepted

According to the Grub2 wiki, if you set/add the GRUB_TIMEOUT directive and change the value to -1, you will cause GRUB2 to pause until you make a decision, which seems to be what you're looking for.

share|improve this answer

Setting the grub time value to -1 will cause it to be disabled. Alternatively, you can hit any key (like a cursor key) to disable the current boot menu countdown. Editing the grub2 config file is documented here. Remember that manual updates to the cfg file are overwritten by update-grub.

share|improve this answer

Think you can either remove the 'timeout' entry or set it to -1

share|improve this answer
    
Agree, set it to -1 – Raystafarian Feb 29 '12 at 16:51
    
Where do I set that? – SaintWacko Feb 29 '12 at 17:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .