Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to run a piece of software (ConnectWise PSA) on my Mac without having to run Parallels. I'm running Parallels now, but want to get away from it if possible.

I use CrossOver, a Windows emulator based on Wine. ConnectWise requires .NET Framework 3.5 to run. According to CodeWeavers (CrossOver creator), it seems like I can install the .NET Framework 3.5. The problem I'm running into is that in order to install .NET Framework 3.5, you have to install .NET Framework 2.0, 2.0 SP1, 3.0, 3.0 SP1 and then 3.5. I can't seem to get past 2.0 SP1.

I created a new WinXP bottle to test this out on and was able to install 2.0 with no issues. When it gets to the point when it's going to install 2.0 SP1, it gives this error message:

enter image description here

I'm not sure why I'm getting this since I'm running a Windows XP emulator.

Does anyone know a workaround for installing .NET Framework in CrossOver or can anyone think of a better way of doing this?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Are you sure it's supported, because CodeWeavers states otherwise.

Furthermore, I would suggest you give Wine a try, couldn't hurt. Look here for more info.

Hope this helps.

share|improve this answer
    
The strange thing is that .NET 2.0 SP1 is not supported, but .NET 3.5 is supported. Don't you have to have 2.0 SP1 installed to install 3.5? –  Matt Love Feb 29 '12 at 22:59
    
Apparenlty not, see here. Mind you, it's still experimental and unsupported. –  Carlos Feb 29 '12 at 23:25
    
Also, it seem you can install it via "CrossTie", though, never tried that before. YMMV. –  Carlos Feb 29 '12 at 23:27
    
Unfortunately, whoever wrote that instructional wasn't very detailed on the steps. I wasn't able to do the registry stuff, so it didn't work. Thanks for finding this for me though. I'll probably wait for CrossOver 11, which is supposed to have built in support for .NET 3.5 Thanks again. –  Matt Love Mar 1 '12 at 1:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.