Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I always get "A DVD driver your PC needs is missing." Then I click "Ok" and "No device drivers were found." pops up.

This occurs right after I select my language and keyboard. How do I fix it?

I'm installing the 32-bit consumer preview on VMware player on a 32-bit Windows 7.

share|improve this question
Try to look for a guide to get a Windows 8 Preview working on VMware, because there are known problems with trying to get Windows 8 working virtually. It might be that this is only specific to the Consumer Preview, but it's worth looking around none-the-less. – Tom Wijsman Mar 1 '12 at 2:33
works perfectly for me, same setup, using an iso – Journeyman Geek Mar 1 '12 at 6:32
I wonder if it's as simple as it's just looking for a DVD rom due to some hard coded expectation, do you not have any DVD roms? If not install a virtual device tool like Daemon tools on the host OS... – Nick Josevski Mar 1 '12 at 6:33
Unless you are married to VMWare player, try virtualbox. there is a great guide for the dev preview and consumer preview HERE – G Koe Mar 1 '12 at 6:35
Which VMware version? Some tech blogs report that version 3.14 cannot be used to install and run W8... (but the articles are from last september and the things change fast...). Virtual Box is a good alternative imho. – climenole Mar 1 '12 at 7:29

I can confirm that in my case it was due to a corrupted download of the ISO file. The size of my file was not correct; and it gave the error mentioned in the question above, here on my VMware vSphere 5.0.

Use a download manager (e.g. Orbit Downloader) and compare the SHA-1 hash of the downloaded file with the SHA-1 value published at Microsofts download page. (Install HashTab, right-click the iso file and click the tab File Hashes) Or download from, as they use a buildin download manager which checks the integrity of the file.

Both Windows Server 8 Beta and Windows 8 Beta seems to run without any problems at my VMware vSphere 5.0 here.

share|improve this answer

In my case it was an incomplete download by Google Chrome. So effectively a corrupt ISO as Peter said. Downloading the ISO again solved the issue. I used Safari and curl to have 2 horses in the race and they both worked just fine.

Compare the SHA1 hash provided by MS on the ISO download page to ensure you have the whole thing. The hash is E91ED665B01A46F4344C36D9D88C8BF78E9A1B39.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .