Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Trying to maintain good security settings on my laptop, I want my home network to be interpreted as private and the university network at school to be interpreted as public. However, my home network is currently showing as public.

Here is what my Network and Sharing Center looks like:

How do I change my home network from public to private on Windows 8 Consumer Preview?

share|improve this question
    
+1 to remove the -1 somebody did. I've only used XP so I suppose this private/public thing is in windows 8 and maybe a bit earlier. Could be the downvoter thought you weren't using the right terminology. A screenshot may have deterred them from having such a thought. –  barlop Mar 1 '12 at 3:23
    
For best security, set all networks as Public. Unless you're hosting file shares or other server-type services from your computer, you shouldn't need to open it up any more than that. –  Iszi Mar 1 '12 at 5:28
    
First make sure that your wireless network is private. Unless you've set a password it isn't. –  Daniel R Hicks Nov 18 '12 at 19:26
    
Are you asking how to change the network itself? If so, why do you say "How do I change my home network from public to private on Windows 8 Consumer Preview?" Are you trying to change a setting on your network or on your machine? And if on your network, why do you tell us all about your machine and nothing about your network? –  David Schwartz Dec 16 '13 at 0:25
1  
How is that related to this question? Are you trying to address Microsoft? –  Tom Wijsman Dec 17 '13 at 14:30

4 Answers 4

up vote 32 down vote accepted

There are a few paths to the correct UI.

"Easiest" : (Use homegroup to get to the UI / No right clicking needed)

  1. Tap Win+W to open the search charm for settings
  2. Type HomeGroup and Click the tile labeled only "HomeGroup"
  3. Click on the "Change sharing settings" button
  4. Then select the "Yes" option which corresponds to private networks

"Most Direct"

  1. Bring up the "Networks" UI via a Click on the network icon from the desktop taskbar or from the system charm (Win-I)
  2. Right Click on your connection and select "Turn Sharing On and OFf"
  3. Then select the "Yes" option which corresponds to private networks

Here is the correct UI:

Network Sharing UI

share|improve this answer
1  
This does not work if the network is detected as 'Public"... but I want to change what it is detected as! –  MrHinsh Aug 2 '12 at 22:15
    
As of Windows 8 RTM, this does work even with a network detected as Public. –  Edward Brey Dec 10 '12 at 4:53
    
This doesn't really address the question. Huynh Son Tung's answer is more applicable. –  Josh May 17 at 13:16
  1. Press Win+R, then type secpol.msc
  2. Click on "Network List Manager Policies"
  3. Double-click on your network
  4. Click on "Tab Network Location"
  5. Set "Location Type" to "Private"

Go back to Network and Sharing Center to check the result.

share|improve this answer
    
+1 for changing the location type without enabling file sharing. Private networks allow for many other relaxed firewall settings besides those needed for file sharing (e.g. remote desktop). –  Jeff Lockhart Jan 30 '13 at 22:31
5  
this worked, I could not get the accepted answer to work at all! –  Jeff Atwood Sep 14 '13 at 9:19
    
same, this works beautifully, and instantly. –  InsidiousForce Oct 25 '13 at 22:01
    
+1 because this works well on the Windows 8 embedded system I have that has many things disabled which probably caused the accepted answer to fail. –  Joel Rondeau Nov 12 '13 at 20:17
1  
This was the hint I needed, the higher voted answer had me turning on sharing for public networks. This answer showed me how to move the improperly designated network from public policy rules to private policy rules. –  Grant BlahaErath Nov 15 '13 at 20:38

Things have changed for Windows 8.1. The public/private setting might be even less discoverable now. Well here is what you need to do:

  • Open the PC Settings (Win+C, Settings, Change PC Settings)
  • Go to Network -> Connections
  • Tap/Click on the network you want to change
  • A page with network details opens
  • There should be a switch "Find devices and content" -- turn it on

Caveats: The switch is not there if the machine is domain-joined and connected to the domain network. I think the switch is also missing if you are connected to an unsecure WiFi.

See also http://windows.microsoft.com/en-us/windows-8/find-pcs-devices-content-on-network.

share|improve this answer
    
This worked for me. Windows 8.1, up-to-date as of 2014-05-17. –  radim May 17 at 15:10
    
The switch "Find devices and content" doesn't show up for me, running as user, not administrator. –  Tom Anderson Jul 6 at 7:13

The HomeGroup troubleshooter worked for me. It noticed that I didn't have any private networks, and fixed the problem by turning my "public" network into a private network.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.