Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On my Windows 7 PC the system becomes locked after 10 minutes of inactivity. Usually I would find this setting next to the screen-saver configuration. The setting is grayed out, however.

I think this is because of corporate group policy. As I am an administrator on this computer I should be able to reconfigure the group policy setting using gpedit.msc.

What is the group policy setting that I need to change to prevent automatic locking of my workstation?

Edit: I don't have configured a screen-saver. I also want to continue to be able to lock the workstation manually.

share|improve this question
3  
Just because the user account is an administrator does not mean you can change any setting on Windows. The domain policy overrides your priviliages. –  Ramhound Mar 1 '12 at 13:57
    
Interesting to know. But where can I find this setting? I'd still like to try it. –  usr Mar 1 '12 at 15:49
1  
It DOES mean he can change any settings. That's the power of administrators - they can take ownership of each and everything... –  Martin Binder Jul 25 '13 at 15:40
add comment

6 Answers

up vote 4 down vote accepted

To disable Lock:

Under HKEY_LOCAL_MACHINE\SOFTWARE \Microsoft\Windows\CurrentVersion\Policies\System, create a new DWORD value named DisableLockWorkstation and set value to 1.

Then restart the computer.

share|improve this answer
    
You are the first to answer the question. I will try this suggestion. –  usr Sep 13 '12 at 13:11
    
Hm didn't work in my case. Maybe group policy is overriding this key? –  usr Sep 13 '12 at 14:08
    
Group policy overrides the value but I log on to the domain once every ~6 months so this works like a charm for me. –  st3inn May 25 '13 at 14:56
add comment

Group policy overrides your settings, but you can mimick user activity to prevent the screen lock. Check this answer for easy how to.

share|improve this answer
    
I since solved the problem using the registry change, but this also looks reasonable as a last-resort solution. Thanks! –  usr Jul 24 '13 at 10:45
add comment

The Group Policy from the domain will likely override any change you make. If this is creating an issue for your work, why not contact the admin and look at solutions. Making changes may be a violation of corporate policy and have consequences.

A quick call should help.

share|improve this answer
    
I will do that. But my scenario is that I keep getting locked while using Remote Desktop from home. This does not serve any purpose. –  usr Mar 1 '12 at 15:49
add comment

Like others have said, the domain policy will generally override any local settings you try to configure for this. There's a couple other things I'd like to add, though:

Be careful tweaking this setting, whether it be via registry or otherwise. I once tried messing with mine on one system (domain policy is to lock after 15 minutes, but I prefer 5 - can't remember what I changed, though) and the system ended up listening to neither the domain nor my preference even after I rolled back the change. In this case, it ended up not running a screensaver at all. That's exactly what you want, but definitely not what I'd intended. YMMV.

Regardless: Unless your system is the sort that requires full-time immediate access, for the preservation of life and/or property (i.e.: 911 Call Center), it is probably against your organization's policy to prevent the workstation from locking. If your system did fall into that category, then it would probably already be configured not to lock. Therefore, it's best to just leave it alone.

Even if you do manage to change the setting permanently, corporate administrators may detect the computer as being out of compliance and force the policy on again. After a few times of doing this, you or your manager may get a memo or visit from your friendly IT Security department.

share|improve this answer
    
But my scenario is that I keep getting locked while using Remote Desktop from home. This does not serve any purpose. We are a small programming shop. There is no corporate IT department. –  usr Mar 1 '12 at 15:50
1  
Even more reason why you should contact whomever administers the domain group policy, and explain the situation to them so they can modify the policy files. –  dotnetengineer Mar 1 '12 at 17:25
    
It looks like you changed this setting in the past. Can you tell me where I can find it? –  usr Mar 1 '12 at 18:25
    
@usr As I said in my answer, I don't recall which setting I modified to tweak the screen saver. I'm beginning to become a bit confused as to exactly which setting you're trying to address here, though. Is the session getting locked while inactive over RDP, or is the RDP session being entirely disconnected. There are two separate settings for these, and the latter has nothing to do with the screen saver. –  Iszi Mar 1 '12 at 19:02
    
The session is being locked. I can see and access the blue lock screen over RD. All programs are still running when I log in. –  usr Mar 1 '12 at 19:27
add comment

Just play some songs in Windows media player by selecting in repeat option.(Mute the volume). Then it never locks or sleeps.

share|improve this answer
    
This is crude, but I can confirm that it works for XP (that was the last time I needed to use that trick). –  Hennes Dec 24 '13 at 20:10
add comment

You can use the Nosleep.exe function. It works like a charm. You need to download it from the internet.

This works on Windows 8/7/2008R2/2003 R2

Download link http://www.symantec.com/connect/downloads/readynosleepexe-prevents-screensaver-and-pc-locking

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.