Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using a MacBook with Snow Leopard. For some reason, I have accidentally enabled Japanese keyboard support (Kotoeri). Now, having disabled it, I face the following problem: My US English keyboard layout has changed.

The keyboard viewer displays some Japanese keys next to command, and in general the keyboard does not look like mine. In addition, some punctuation characters have moved to different keys, and some to inexistent keys.

Just to illustrate: The Yen sign appears now on the left of the Backspace, the underscore sign has moved to an inexistent key between Forward Slash and Right Shift keys. And there are more changes like that. The keyboard layout is set to US English.

I have tried Ukelele utility, but it only allows to remap existing keys, not to change them.

How can I roll back this layout to factory default?

share|improve this question
    
So what's currently selected in System Preferences → Language & Text → Input Sources? –  slhck Mar 1 '12 at 13:55
    
Enabled keyboards: US English, Russian, Keyboard and Character viewer. –  TimSparrow Mar 1 '12 at 14:28

3 Answers 3

A solution that helped in my case: I installed KeyRemap4MacBook, and enabled 1 setting:

  • Use US Keyboard layout

Now the keyboard works normally. The keyboard viewer, however, displays the Japanese keyboard until I click a key, then it shows a normal US keyboard.

Still it is a hack, and I will look for a solution that eliminates the problem completely.

share|improve this answer

I hope this instructions that i found usefull if its not let me know.

here is the link for more detail: http://www.ehow.com/how_2065339_change-keyboard-language-mac-osx.html

Instructions

1

Click the “System Preference” icon in the Dock, or click the Apple icon in the upper left corner, then click “System Preferences...”

2

Click “Language and Text,” then the “Input Sources” tab.

3

Check the language or languages you want to be available for keyboard layouts. If you check multiple check boxes, click “Show Input Menu in Menu Bar” to make all selected languages available when you click the flag icon in the menu bar at the top of the screen. For example, if the U.S. flag is displayed, you can click it and select another keyboard language from the drop-down menu.

share|improve this answer
    
As far as I read it, the OP has already changed the keyboard layout back to US English. –  slhck Mar 1 '12 at 13:39
    
Thanks for the reply, but this does not revert the key mapping on the English keyboard back to English, it still stays Japanese-English, with the Yen sign on top and underscore sign on a non-existent key between Right Shift and Forward Slash keys –  TimSparrow Mar 1 '12 at 13:45
    
The keyboard layout in my case is same as here [link]superuser.com/questions/314783/… –  TimSparrow Mar 1 '12 at 14:02
    
The solution suggested in that thread does not help –  TimSparrow Mar 1 '12 at 14:09
    
@Tim Did you try the solutions there? –  slhck Mar 1 '12 at 14:10

According to this blog post, deleting the keyboardtype plist file fixed the author's keyboard layout issue:

After a lot of Googling, I found that it’s necessary to delete a file to make Mac OS completely forget keyboard settings: /Library/Preferences/com.apple.keyboardtype.plist

One other thing to try is the OS X Keyboard Setup Assistant - instructions from the Apple Support page are:

If you’re having trouble with your keyboard, you may need to specify the type manually. You can use Keyboard preferences to open Keyboard Setup Assistant and specify the keyboard type.

  1. Choose Apple menu > System Preferences, and then click Keyboard.
  2. Click Change Keyboard Type.
  3. Follow the onscreen instructions when Keyboard Setup Assistant appears.

There is also a related Apple.SE answer that discusses solutions to a similar problem.

share|improve this answer
    
Still does not work: there is no 'Change Keyboard Type' button on the Keyboard preference pane, and manual invocation of Keyboard setup assistant produced the following result: System/Library/CoreServices/KeyboardSetupAssistant.app/Contents/MacOS/KeyboardSe‌​tupAssistant ; exit; 2012-03-02 17:53:46.409 KeyboardSetupAssistant[277:903] No unknown keyboard connected - terminating logout –  TimSparrow Mar 2 '12 at 14:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.