Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently migrated from Fedora to Ubuntu 11.10 on my laptop. I'm really happy with the change so far, except that I often have the need to run a series of hour-long jobs overnight, and as best I can tell, Ubuntu goes to sleep after about an hour and a half nomatter what I do.

I can only tell because when I hit a key to wake the screen up in the morning it takes a few seconds (normally comes up instantly), and when I check its progress a series of tasks that should've taken 4 hours max is less than halfway done. I know it's not the job just taking longer than it should - I'm basically running the same thing over and over, and I inserted date commands between each run and I can see the jobs running exactly as long as I expect, up until it hits the point where it just stops, usually after the first or second run.

I would expect this to be fairly trivial to solve but it's really important for what I'm doing that I get this figured out. I have the power settings on "Don't Suspend" regardless of whether it's charging or not (and I obviously leave it charging when I do this), I leave the lid up, and I tried installing Jupiter and setting it Maximum Performance. No dice. Any help would be greatly appreciated.

share|improve this question
1  
So I found a solution, I installed Caffeine and set it to force the computer to stay awake when bash is on, which seems to have solved my problem. –  Reiik Mar 6 '12 at 15:04
add comment

2 Answers 2

This site lists what you have to do.

Power >> System Settings >> Hardware >> Power Management
share|improve this answer
    
I have already done that, I changed that setting as soon as I installed it but it doesn't seem to be helping. That's largely why I'm confused. –  Reiik Mar 1 '12 at 16:26
    
Edited because I just got disciplined for link rot. –  sealz Mar 1 '12 at 16:28
    
@harper89 lol no problem –  HackToHell Mar 1 '12 at 16:30
    
@AddisonMayberry I did the same and had no issues. –  HackToHell Mar 1 '12 at 16:33
add comment

It seems to be a bug other people are reporting. Here is a fix that may work. There is also another link under that article that may be more associated with your problem.

The fix is a little lengthy so I won't post the whole thing.

share|improve this answer
    
I tried this but no success, I figured it out using a different method. Thanks though. –  Reiik Mar 6 '12 at 15:02
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.