Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Hi I tried to install octave on my RedHat 5 Linux. I typed command as

yum install octave 

Then, it complained as following :

gcc-gfortran-4.1.2-44.el5.x86_64 from installed has depsolving problems
  --> Missing Dependency: libgfortran = 4.1.2-44.el5 is needed by package gcc-gfortran-4.1.2-44.el5.x86_64 (installed)
Error: Missing Dependency: libgfortran = 4.1.2-44.el5 is needed by package gcc-gfortran-4.1.2-44.el5.x86_64 (installed)

However, when I typed command as

yum list libgfortran

It did show something as

Loaded plugins: rhnplugin, security  
Installed Packages  
libgfortran.x86_64               4.1.2-44.el5               installed             
Available Packages  
libgfortran.i386                 4.1.2-52.el5               rhel-x86_64-client-5  
libgfortran.x86_64               4.1.2-52.el5               rhel-x86_64-client-5  

Doesn't it mean I have libgfortran 4.1.2-44.e15 installed already ? Why does it still complain ? Does anyone have any idea how this can be solved ? Thank you very much

share|improve this question
up vote 0 down vote accepted

libgfortran = 4.1.2-44.el5 you have installed is probably 32bit version. Try install the 64bit version and that should resolve the problem.

share|improve this answer
    
Thank you very much. I found out my epel package is i386 version so I also installed the 32 bit version of libgfortran 32 versions. And it works now. – Cassie Apr 27 '12 at 21:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .