Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a strange problem.

I got Virgin 30MB broadband installed yesterday (its been over 24 hours since it was activated)

FYI I am in the United Kingdom.

My home network goes like this:

Item (Speedtest.net result)

Router
- TP-Link Switch
-- Computer (0.01mb dl, 3.00mb ul)
-- IP Phone (Connects)
-- Server (Does not connect)
-- Netbook (30mb dl, 3mb ul)
-- Laptop (30mb dl, 3mb ul)

Wireless
- iPhone (20mb dl)
- iPad (20mb dl)

Can anyone help be get an actual speed on my computer and get my server to connect? I tried to download a 2.5mb file off the virgin website and it said it would take 6 hours. I can browse the internet very slowly on my computer, but my server cannot connect at all!

The server is ubuntu-server.

Any help would be greatly appreciated. Calling customer services is a last resort since they will say have you tried turning it off and on again?

I used to have BT broadband (2 days ago) with the exact setup and all was fine.

I have restarted everything, reset the router and switch.

share|improve this question

migrated from serverfault.com Mar 1 '12 at 22:30

This question came from our site for professional system and network administrators.

    
1. Bandwidth (capacity) and Speed (latency) are not the same thing. 2. Nice reference to "The IT Crowd". –  joeqwerty Mar 1 '12 at 13:16
    
I said that I tried to download a 2.5mb file and it said it would take 6 hours, so it is actually slow :( And I love the IT crowd :) –  Adam Tester Mar 1 '12 at 13:18
    
I think you will have to phone customer services for this one. It may well be that your cable modem and/or line's power settings are a bit off and they will need to adjust them for you. –  RobM Mar 1 '12 at 16:25
    
I rang customer services and they said it was a problem with my pc :( –  Adam Tester Mar 1 '12 at 16:27
    
I have put the router into 'modem' mode and now it works! Although I don't have wireless... I'm trying to set up an old router for that. –  Adam Tester Mar 1 '12 at 16:28

4 Answers 4

Try transfering some files between the slow computer and the netbook. If local network traffic is slow, you've got a problem with your router/cables/network card.

Try plugging the computer directly into the modem without the router and see if you still get the slow speeds.

As for the server...check that it can ping your router, then if it can ping a public IP address. Then a DNS name. If it fails at one of those steps, it'll help narrow down the problem.

share|improve this answer
    
Thanks for the reply, I've moved a 7GB file front my pc to the netbook (all going through the switch) and it transfers at around 13mb/s. I have tried to connect the PC directly to the router but same speed. –  Adam Tester Mar 1 '12 at 13:32

As you can get the sold bandwidth from different source (iphone, notebook..) the adsl line is not the problem there.

not a wifi problem, since all having issue are using ethernet.

Try: -swap cables from working one and problem one. Check if both are having same result after that.

On the server: does ifconfig -a shows up that you have an ip ? Can it ping the router and other devices on the local network ? does ping 8.8.8.8 works ?

try to set a static ip as a try. Also check it's not using dns server from the previous ISP

share|improve this answer

Use wireshark or tcpdump to see whats actually happening at the packet level on the wire.

Also an IT Crowd fan.

share|improve this answer
up vote 0 down vote accepted

I have solved the problem. So I'll post it in case anyone else has this issue.

In the Virgin router there was an option called Modem mode, which reset the router properly, then I took it out of modem mode. It cleared the MAC addresses and the problem was solved. So it was a problem with the router.

I rang up virgin and they said it was defiantly my computer, I proved them wrong :)

Thanks for the help guys!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.