Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I Recently upgraded to Windows 7 (Business) RTM from Vista Business and everything is going great, it fixed the BSOD I was getting and the performance of my laptop is improved.

However; during the upgrade, something seems to have gone awry with my .NET 2.0 installation.

When attempting to install FlashDevelop, I get the following error from the installer package

You need to install Maicrtosoft.NET 2.0 runtime before installing FlasgDevelop. You Have .

I have a previous release of FD installed from before the upgrade and this still works fine.

So I gave up on the new version of FD and got on with my day.

Then I tried to install the Microsoft SQL Server Database Publishing Wizard 1.1 and that says I am missing a couple of prerequisites, one of which is .NET 2.0.

When I download the .NET 2.0 runtime the installer fails, telling me that

This product is already installed as part of the operating system.

Does anyone have any idea how to make my computer recognise that .NET 2 is in fact installed.


I've checked Windows Features and everything relating to .NET is already installed.

I've also been through my list of installed programs looking for .NET to in an attempt to uninstall it but it isn't there. In fact, the only thing that looks like a .NET distro that I am able to uninstall is the 3.5 Compact Framework.

share|improve this question

I think although .net is part of Windows 7, it can be turned on and off. Open control panel, choose programs, then choose "Turn windows features on or off". There should be an option then for turning on .NET support.

The OP has confirmed that .NET 3.5 is listed as installed in windows features. My next suggestion would be to try removing and re-installing .NET 3.5 SP1. You should be able to remove from the previously mentioned windows features list. Then download the .NET 3.5 SP1 installer and install that. Then run a check for updates to get the last few bits.

share|improve this answer
Hi pip. Everything in Windows Features that even mentions .NEt is already installed. Is there any item in particular you think I should be looking for> – Greg B Sep 11 '09 at 14:24
No. When I checked my Win 7 PC there was an entry for .NET 3.5.1. It is that entry that I was suggesting. – pipTheGeek Sep 11 '09 at 17:08
I have updated my answer with another suggestion, basically the same un-install/re-install sa suggested by @harrymc – pipTheGeek Sep 11 '09 at 17:15

Have you tried to uninstall all your .net frameworks and then re-install 3.5?
I have it from good authority that if 3.5 is correctly installed then the prerequisite of 2.0 and upwards should automatically be treated as installed.

share|improve this answer
Correct. The solution offered by pipTheGeek is fairly much the route to take. – BinaryMisfit Sep 11 '09 at 12:15
This is a route I'd like to avoide if at all possible. But worth a try as a last resort – Greg B Sep 11 '09 at 13:34
It's a route I've gone before. Apart from the ultra slowness of .Net (un)installations, it's not so destructive. If it doesn't work, repeat it with the addition of the Cleanup Tool mentioned by Dubs. Do I need to mention restore point or (even better) a disk-image backup? – harrymc Sep 11 '09 at 15:41

Try cleaning up your .NET framework installation using the .NET Framework Cleanup Tool:

I've run into this before with some Tax software. In the case of the tax software, the installer was looking for version 2.0 of the .NET framework...EXACTLY version 2.0.

If I had .NET 2.0 SP1, it assumed I did't have the framework installed -- FAIL. If I had .NET 3.5, same story -- FAIL.

A less-than-perfect solution was to downgrade my .NET framework to 2.0. Then install the software. Then upgrade my .NET framework back to 3.5 SP1. It was a pain in the butt, but it worked.

share|improve this answer
As an alternative, see if there is a more up-to-date version of the FlashDevelop installer from their website. – Dubs Sep 11 '09 at 14:42

The .NET Framework 3.5 is definitely installed on Windows 7 by default, and is backwards compatible supporting previous versions. That being said, if the FlashDevelop is looking specific Framework files marked with version 2 when it's doing a prerequisite check, that might change everything. Is there any switch to force the install FlashDevelop, or ignore or surpress any warnings?

share|improve this answer
Hi Matt, thanks for your thoughts. I'm more concerend with the bigger issue that .NET 2 seems not to be installed "properly". Fixing that will solve my other installer based issues. – Greg B Sep 11 '09 at 14:22
3.5 is installed correctly for new Win7 installations. Since this is an upgrade from Vista, who knows what went wrong? – harrymc Sep 11 '09 at 15:35

In my experience, .net 2.0 apps are NOT generally supported by .net 3.5 - it's not different versions of the same framework, it's different frameworks with different (but similar) functionality and you need to have .net 2.0 installed for applications that require .net 2.0 and .net 3.5 installed for applications that require .net 3.5 - .net 3.5 does not "subclass" .net 2.0. So what I don't get is whether that has changed recently (Windows 7) and if anyone can clarify this it'd be useful.

share|improve this answer
up vote 0 down vote accepted

It seems to be an issue with upgrading from Vista. In the end I had to flatten the laptop and install Windows 7 fresh.

Not the best answer, but it's what I had to do...

share|improve this answer

You can try to use the cleanup tool as administrator (use method 2) and then run sfc /scannow in evevated command prompt.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .