Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

We are looking at rolling out a new GIS web app (served up from servers on our network) but we are having issues with the apps speed on certain PCs.

In our testing we identified two physically identical PCs (same batch from the same manufacturer, both Core i7s with 4 GB RAM, etc) from two different departments. One runs the web app perfectly, intensive requests finish in 2-4 seconds. The other machine however takes between 15-30 seconds for the same request.

We tried multiple users on each machine (the same set of users between each PC) and found that no matter the user the speed was always the same on the PC.

We thought it may be the physical location (they are in separate building connected by fiber) but after physically swapping the PCs, the computer that was fast remained fast and the slow computer remained slow.

The computers are in identical OUs and groups in Active Directory. The same policies are applying to each.

Settings in Internet Explorer have been set the same between the two. I manually adjusted all services on the slow machine to be the same as the fast machine (I had a nice report out of out Helpdesk system to go by.)

actxprxy.dll is registered on both machines.

What have I missed? Where else do I need to look?

share|improve this question
Can you describe in more detail what is "slow"? For example: query happens quickly and you can see query request on server side as quickly as the PC's that work, but response from server is slow? Downloading the data is slow? Is there a visualization that is taking a long time to render visually or "paint"? Is there intense JavaScript involved? If so does the user have any ActiveX or other plugins installed that might be wreaking havoc on any JavaScripts that run? – Joshua Mar 2 '12 at 4:10
@Josh I'll post screenshots of the dynatrace results for a request on Monday. Neither machine has any IE plugins installed. – Windos Mar 3 '12 at 21:47
Time to bust out the profiler and debuggers. . . – surfasb Mar 4 '12 at 0:25

Several things come to mind that may be possible:

  • Top guess: Network line quality or network card failure - any chance one is one Wifi and the other is on Cat 5/6? Check ping / network type tests to verify.
  • Antivirus scanner?
  • Virus or other malware? One way to test might be to testing using a different browser - i.e. Chrome or Firefox.
  • One PC has mechanical hard drive, one has an SSD?
  • Background apps that might be eating bandwidth, logging data, or otherwise sharing / consuming resources?
  • Differing graphics hardware being used? One might be using Intel HD 3000 by default (built into Core i7) and the other might use the external (if it has one)? This is configured in Drivers or BIOS.
  • Drivers broken or out of date? Specifically network or graphics drivers.

Have you done other tests -, ping tests, DNS tests, etc.?

share|improve this answer
Both machines are physically identical, they are both running onboard intel gigabit ethernet, both using the i7's HD 3000 graphics, both have mechanical drives. We've tried disabling (and going so far as to uninstall) antivirus (McAfee) on both machines. Drivers appear to be "working" and are the same versions between PCs (they were build from the same image and updates are applied via WSUS.) I'll try manually updating drivers on Monday. I'll also have to recheck the background apps and do another round of virus scans. Also all speed tests are fine. – Windos Mar 3 '12 at 21:33

It is probably a browser caching issue, I assume your using an external API set for the GIS information.

Make sure your using the most current version of the browser of your choice and check the cache settings in each to make sure they are set low. Have you tested the speed on the slow machine using other browsers like Firefox or Chrome?

share|improve this answer
We've tried both Chrome and Firefox but neither work (not the browsers fault... it's because of how the app was written.) We're using IE 8 and will only be upgrading to IE 9 as a last resort (it does make a slight improvement, but only in the renedering which is a small portion of what is happening.) The IE settings on both PCs are identical (including cache.) – Windos Mar 3 '12 at 21:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .