Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm hoping someone here might help me with a problem that's driving me mad for many, many months.

Some background:

I'm running a Windows 7 x64 Ultimate SP1 in English, all language, regional, and location settings set to English (UK where possible) – except for the language for non-unicode programs (system locale), which is set to Polish. Why? I'm from Poland and do need polish characters to display good in all apps. Otherwise, I live in the UK and use English for just about everything.
I have MS Office 2010 x64 installed in English – Word, Excel and Powerpoint only.

The problem:

From time to time I need to write something in Office 2010 and when I do, the spellchecker always decides it's better to spellcheck my documents and presentations in Polish. Problem?

  1. I don't have the proofing tools for Polish.
  2. I write everything in English (U.K.)

hence, I get no spellchecking whatsoever.

my MS Office Language Preferences look like this:

When I open any document (will use word as example) the status bar tells me spellcheck lang is Polish…

In PowerPoint it's English UK when it starts, but changes to Polish for each text field as soon as that text field contains at least one character – go figure.

If decide to set the proofing language (still in word):

Sure enough, Polish is selected. Notice both checkboxes are disabled.

Even if at this point I choose English UK and click Set as default the proofing language still changes to Polish as soon as anything is typed (and is set to Polish when opening new files, contrary to what the popup says).


I tried googling around and found that lang auto detection based on locale can be disabled in registry by changing the value of the LangTuneUp key at this location HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Common\LanguageResources to Prohibited.

Done that, many moons ago, and no joy.

I've also read here on SuperUser about a similar problem, but the solution used apploc to change this per application - which is something i'd like to avoid. So here's my cry for help. Is there anything I can do to make office stick to English U.K. for good? I'm happy to try anything and give more info as required. Hints on how to prevent this in other applications also welcome.

share|improve this question

1 Answer 1

Possible solution in MS Office

Change Normal style and apply the desired language setting.

Select English (U.K.).

(and is set to Polish when opening new files, contrary to what the popup says).

It solves the above issue. Every time you launch Word, it should be set to English (U.K.).

Even if at this point I choose English UK and click Set as default the proofing language still changes to Polish as soon as anything is typed

When you type in Polish character, it may recognized as Polish but spelling and grammar are not checked. Only English (U.K.) one would be checked.

Related Answer: http://superuser.com/a/362894/163596

share|improve this answer
    
Welcome to Super User! Generally we like answers on the site to be able to stand on their own - Links are great, but if that link ever breaks the answer should have enough information to still be helpful. Please consider editing your answer to include more detail. See the FAQ for more info. –  slm Apr 4 '13 at 15:27
    
Sorry. Actually I would like to comment under the post. But I couldn't. –  Ivan Chau Apr 4 '13 at 15:39
    
Yeah, you need to earn a higher rep to be able to leave a comment. Keep answering questions and you'll get enough points. –  slm Apr 4 '13 at 17:46
    
Thanks for responding to such an antique topic! I've checked out the linked thread and even the blog linked to in there to make sure I'm doing it right (not that it's rocket science). Still no joy :/ changing language to uk english doesn't actually modify the style as that selected as default (the language change doesn't appear in the style description field). Even changing the setting to us english results in a switch to Polish soon as a document is opened (even though this modification is listed in the description). Creating my own style doesn't work either, still changes to Polish. –  Gyumaou May 17 '13 at 11:23
    
That sound strange. Make sure in Modify dialogue the "New documents based on this template" on the bottom is checked. In my case, I use own locale version of Windows and Office and modified the default "Normal" style to "UK". Everytime opened document is sticked with the UK setting. I suspect the cause of the problem may related to language for non-unicode programs or input method. –  Ivan Chau May 22 '13 at 14:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.