Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to format IMEI numbers in Excel according to RIM (Blackberry) conventions: XXXXXX.XX.XXXXXX.X

I enter them in excel without any periods and use the "special format" cell properties so it displays right. This works kind of: ######-##-######-#

However, when I replace the dashes with periods (######.##.######.#) Excel automatically changes it to ###.###.###.###.###, 5 groups of 3. It does this too when I prepend it with a space.

Does anyone know how to disable this behaviour or a workaround?

share|improve this question
add comment

1 Answer

up vote 3 down vote accepted

Try ######"."##"."######"."#. Works in Excel 2010. Places literal .s - anything within quotes is literal rather than whatever special meaning it may hold.

An interesting note, Excel 2010, ######.##.######.# displays the 15 digit number as XXXXXXXXXXXXXXX... (yes, three literal dots at the end).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.