Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I made a task in Windows that's supposed to run 10 minutes after the hour every hour. However, when I look at the task in the task scheduler, it will say it ran at XX:09:59 instead of XX:10:00. Here is a screenshot:

enter image description here

You can see that I created the task at 12:10. The last time the tas ran was 2:09:59. The next scheduled task is 3:10:10. This isn't a problem because I don't really care when the task runs as long as it's once an hour. I was just wondering why this is happening. I am on Windows Server 2008 R2.

share|improve this question
    
Did you have it specificly set to "at task creation/modification"? When you mention the time it was created? . (what was the designation for "begin the task") . Did you put in a Delay? I thought mabey delay was offset them here and there so they would not all work "on the moment of the hour" ? –  Psycogeek Mar 2 '12 at 17:23
    
@Psycogeek: I created the task before 12:10. I set it to begin the task at 12:10 and to repeat every hour. –  Di Zou Mar 2 '12 at 17:35
    
Did You set the "begin the task" "on a schedule" ? –  Psycogeek Mar 2 '12 at 18:08
    
@Psycogeek: Yes. –  Di Zou Mar 2 '12 at 18:14
    
well this is off-topic, but dont you worry that using the "schedule" it will not start at all because the time is passed or not there yet? I dont fully understand it myself, I am just interested in using it again for other things. If the only interest that it run once an hour, I have been using the "at startup" because I dont know how either. –  Psycogeek Mar 2 '12 at 18:18
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.