Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have just switched to zsh, and I would like to bind Home, End and Delete keys such that they would act similar to how they do in bash.

I have found some commands that work if I enter them directly into the command line:

bindkey '\eOF' end-of-line
bindkey '\e[3~' delete-char
bindkey '\eOH' beginning-of-line

Yet those commands do not take any effect when they're part of the zshrc. Other zshrc commands work fine. I do remember to restart terminal after each change.

I'm using ubuntu 11.10.

Please help, I have tried to find a similar questions, yet I can't find any solution.

share|improve this question
    
Solved by: bindkey '^[OH' beginning-of-line bindkey '^[OF' end-of-line bindkey '^[[3~' delete-char –  Alex Mar 2 '12 at 23:34

2 Answers 2

You could try the things from here?

Also, have you tried putting the bindkey commands at the bottom of "$HOME/.zshrc" to ensure they are not being over-ridden?

share|improve this answer

Comment by OP:

Solved by:

bindkey '^[OH' beginning-of-line
bindkey '^[OF' end-of-line
bindkey '^[[3~' delete-char
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.