Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have identified a very interesting problem with Microsoft Excel 2010 on a client's computer.

When opening an Excel file located on a shared folder or mapped network drive, Excel takes 2-3 minutes to open. There are about 1000 other Excel files in this folder. While Excel is "loading", I can actually see a progress bar moving along the top of Windows Explorer. When this progress bar completes, the files opens up in Excel. This is reproduceable 100% of the time, regardless if the file has already been just opened.

If I move one of the excel files into a network folder on the same remote machine (I simply created a folder inside of our excel folder named "Speed Test"), files open up instantly.

My best assumption is that Excel is actually scanning the entire folder before it will finish loading each file. How can I stop Excel from doing this? It is important to note that Excel is usually open, with the correct file showing, but completely unresponsive, until the progress bar has completed inside of Windows explorer.

I've attached a few screenshots of what it looks like.

Before clicking on the file Before clicking on the file

Excel opens prompty, but locks up while it is "loading" Excel opens prompty, but locks up while it is "loading"

If I go back and look at Windows Explorer while I'm waiting for Excel to respond, there is a progress bar. When the progress bar completes, Excel becomes responsive If I go back and look at Windows Explorer while I'm waiting for Excel to respond, there is a progress bar. When the progress bar completes, Excel becomes responsive

share|improve this question

5 Answers 5

Possibly this is Office File Validation helping you out. It may have been installed in an update to Windows. http://support.microsoft.com/kb/2501584 Possibily the same issue as this SO question

share|improve this answer

This worked for me (I'm running IE8 and Excel 2010 on 64-bit Windows 7 box):

  1. Start Internet Explorer 8
  2. Go to "Tools" menu
  3. Go to "Internet Options"
  4. Go to "Security" tab
  5. Go to "Local Intranet"
  6. Click on "Sites" button
  7. Uncheck "Automatically detect intranet network"

Now your Excel spreadsheet should open instantly.

share|improve this answer
    
Tried to edit here is what I attempted to write: I found a method that seemed to work for me. Please not I am currently using IE8 and Excel 2010 on a 64-bit Windows 7 computer. 1. Start Internet Explorer 8 2. Go to "Tools" menu 3. Go to "Internet Options" 4. Go to "Security" tab 5. Go to "Local Intranet" 6. Click on "Sites" button 7. Un-check "Automatically detect intranet network" Now your Excel spreadsheet should open instantly. –  Griffin Mar 14 '13 at 17:12

Same problem, strange solution, but it worked for my friend. This long loading process started without known reason, and was torturing my friend for a month. I tryed During "loading process" start Task Manager and kill Excel. It still closed very slowly. But after it closed, next time (and every time after) files are opening fast. (Win 7 + Office 2003)

share|improve this answer

Printers / printer drivers. Select a different printer as default, test to see of Excel opens faster and performs better. Makes a big difference with my users.

share|improve this answer
    
This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post. –  Scott Nov 27 '13 at 1:19

For almost all Office issues, try starting in safe mode and turn off all plugins (especially the plugin send to bluetooth if applicable) - this should help.

share|improve this answer
2  
this should help could you expand more on what OP should do if this does help? Should OP try to identify one or more plugins that is causing the slowness? Should OP always open in safe mode? Expanding your answer for follow-up questions would make it a more quality answer. –  Raystafarian Mar 3 '12 at 12:26
1  
Man... dont "-1" my answer just becouse You cant access safe mode in Office. –  Adam RichardSon Mar 3 '12 at 19:21
1  
Go to a folder where Your Office is installed and open (in your case) Excel with CRTL key holded. Then go to the plugin tab and uncheck all of them. –  Adam RichardSon Mar 3 '12 at 19:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.