Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I started my morning with installig windows 8 consumer review on my Virtual Box. I spent 2hrs and still unble to find the solution (How to install it on virtual box I am following this tutorial

Error from Virtual Box: Enable VT-x support!

I googled and found some modification requires in "system->Acceleration" tab setting in virtual box. But "Acceleration" tab is disabled at my end.

I am using x86 platform (I know these system never designed by considering fact of virtualization :( ) need your suggestion to resolve this problem!

Thanks, Vipul

share|improve this question

migrated from stackoverflow.com Mar 2 '12 at 23:54

This question came from our site for professional and enthusiast programmers.

2  
What CPU does your system have? – Joachim Isaksson Mar 2 '12 at 18:39
    
I assume you are installing it on a virtual box so that you don't need to overwrite your main OS to avoid a re-install? If this is the case then I think your better simply creating a new partition on your drive and installing there, then when your finished playing (won't be long because it still isn't perfect) you can delete the partition. – Matt Donnan Mar 2 '12 at 19:47
    
@Matt: Thanks. I like your idea! I will give try for that. – Vips Mar 3 '12 at 3:13

Not all x86 CPUs are created equal when it comes to virtualization. VT-x is an Intel feature that wasn't included in all CPU models.

See http://en.wikipedia.org/wiki/X86_virtualization#Intel_virtualization_.28VT-x.29 and http://ark.intel.com/

share|improve this answer
    
thanks a lot for your exact information. I used Virtual Box user guide. you can see here link (search for "Unfortunately, the x86 platform was never designed to be virtualized") I think, I assumed thing w/o enough searching... Thanks again – Vips Mar 3 '12 at 4:36

I just did the same thing, but followed this blogs instructions. There are some modifications you need to do to the Virtual Box. I would try the steps described here.

http://www.zdnet.com/blog/btl/virtually-windows-8-how-to-set-up-the-consumer-preview-in-virtualbox/70330

share|improve this answer
    
@EI: thanks for the link. I will get back on this. – Vips Mar 3 '12 at 4:48

I used the same settings as for the previous Win8 version, and it worked. I will list all the settings in the tabs:

(I am translating names from my native language to english, sorry)

System:

  1. Tab mainboard: memory set to 2048 MB (I use 32bit, for 64 use double that), IO APIC is enabled, other checkboxes are unchecked
  2. CPU, 2 cpus, execution cap is set to 100%
  3. Acceleration, botch checkboxes set

Screen:

  1. Video: 16 MB, 3D acceleration enabled, 2d acceleration is off
  2. Remote desktop enabled, this is how I use Win8, VB window sux

Hard Drive:

  1. I use dynamically allocated storage, 43 GB

Sounds:

  1. Defaults

Network:

  1. Bridged card

All the rest is default.

As far as I remember your CPU must support hardware virtualization to make it work.

share|improve this answer
    
Dear Tom, Thanks for your detailed steps. But at my case, System step(3) Acceleration tab is disabled. – Vips Mar 3 '12 at 4:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .