Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Possible Duplicate:
How do I disable “you need to format this disk” message in Windows Vista/7?

I use external hard disks a lot, and sometimes they are formatted as disk types that Windows does not recognize (ie: anything other than FAT/NTFS). Every time I leave the disk plugged in, Windows provides me with a prompt every time it attempts to auto-mount the disk. ie:

"The following disk uses an unrecognized partition type or is not formatted. Would you like to format it now?"

I always click no, but on one unfortunate occasion, I accidentally hit enter (nice going Microsoft, default to blast away a drive with unknown partition type for me).

Is there a way to tell Windows to stop nagging me about unformatted or unrecognized drives?

Thanks!

share|improve this question
    
To clarify, are you intending to try to write a device driver or other application to resolve this problem, or did you just want to know if there was already a known solution? –  Harry Johnston Feb 7 '12 at 20:13
    
I am not attempting to write a device driver. I just want to disable the system dialogs and pop-up notifications that Windows gives my every time the drive is detected by Windows, offering me to format the drive. I don't want to format it, and I want Windows to stop asking me to format it. –  Gir Loves Tacos Feb 9 '12 at 17:14
add comment

migrated from stackoverflow.com Mar 3 '12 at 3:39

This question came from our site for professional and enthusiast programmers.

marked as duplicate by Daniel Beck Aug 19 '12 at 13:26

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer

up vote 0 down vote accepted

This is best answered by another post I randomly found on my own:

http://superuser.com/questions/49382/how-do-i-disable-you-need-to-format-this-disk-message-in-windows-vista-7

Perfect!

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.