Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a hardisk that is failing (windows wouldn't even boot off the recovery disk). I was able to make an image of it in linux using ddrescue, but linux can't mount the thing. In linux I get the following error when trying to mount the image.

sudo mount -t ntfs -o loop recovery.image mounted                                                                                
Failed to read last sector (1201371135): Invalid argument
HINTS: Either the volume is a RAID/LDM but it wasn't setup yet,
   or it was not setup correctly (e.g. by not using mdadm --build ...),
   or a wrong device is tried to be mounted,
   or the partition table is corrupt (partition is smaller than NTFS),
   or the NTFS boot sector is corrupt (NTFS size is not valid).
Failed to mount '/dev/loop1': Invalid argument
The device '/dev/loop1' doesn't seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?

I try to use ntfsfix on linux and I get the following:

ubuntu@ubuntu:/media/LaCie$ sudo ntfsfix recovery.image 
Mounting volume... $MFT has invalid magic.
ntfs_mft_load(): Failed.
Failed to load $MFT: Input/output error.
Failed to startup volume: Input/output error.
FAILED
Attempting to correct errors... $MFT has invalid magic.
ntfs_mft_load(): Failed.
Failed to load $MFT: Input/output error.
FAILED
Failed to startup volume: Input/output error.
Volume is corrupt. You should run chkdsk.

Is there a way in windows that I can run chkdsk on an image? Thank you!

share|improve this question
    
thats my problem this side. i booted with gparted and realised that the filesystem type is UNKNOWN. i tried some testdisk and it also told me there r bad sectors in that partition. im still trying to figure what can i use to boot up a do a chkdsk on it –  user130438 Apr 26 '12 at 15:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.