Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I open CSV files in Excel 2010 I get entire rows in cells, not distributed according comma separation.

How to control this?

share|improve this question
add comment

2 Answers 2

up vote 12 down vote accepted

Open Excel and go to the data tab - from text - select the file - import - delimited - next - comma - next - (settings) - finish.

This will import your CSV file into Excel and will delimit it appropriately. Note if your CSV file uses something other than commas as separators, just choose that during the option selection phase.


Alternatively, if you've already opened it you can select the column and go to data - text to columns - delimited - comma - finish and that will break up your column across the row(s).

share|improve this answer
add comment

You can do it using the import wizard, or you can do it by opening the file in a text editor and adding

sep=,

as the first line of the file.

share|improve this answer
1  
Do you happen to know if there is a special string to tell excel what the decimal separator should be? –  Sergio Dec 9 '13 at 22:18
    
I'm afraid I don't. I'd be interested to find out though. Let me know if you find anything. –  ForbesLindesay Dec 10 '13 at 17:51
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.