Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an odd problem with an external drive. I'm formatting it connected to my laptop prior to connecting it to my router. The HDD enclosure has both an eSata and USB connections.

Generally, I connect it via eSata to my laptop. I created my partitions and connected it to the router, but I see partition information that is different than what I created.

After chasing leads concerning large HDD size, I mindlessly connected the HDD to my laptop with USB.

Lo! I see the same partitions as the router.

Attached are screenshots using the same program and the HDD in question. The only difference is the connection. For the first, I connected via eSata and hit "refresh" on the partition program. Then, turned off the HDD, disconnected the eSata cable, and connected via USB. Power and refresh.

eSata: reports a total HDD size of 2328 GB, with four partitions (the third being 1.96TB) USB: reports a total HDD size of 280 GB, with three partitions (the third being 279 GB)

Any idea why this is happening?

Partitions when connected via eSata Partitions when connected via USB

It looks like it clearly is an issue of the 4K sector size and not playing nice with the USB enclosure. I tried it eSata and USB in Windows and Linux and it appears consistently that eSata is reporting correctly, USB incorrectly.

share|improve this question
I ran into a similar problem with the Fantec DB-ALU3e-6G USB3 + eSATA HD enclosure (asmedia ASM1153E USB3.0 to SATA bridge). Fortunately, for this one, a firmware update fixes the USB end to report the same sector sizes as on the eSATA end. See…. – Brecht Machiels Mar 17 '15 at 20:18
Good tip @BrechtMachiels - if someone else has the option to upgrade firmware that may solve this issue (which should be less common as newer enclosures and adapters will support it by default). – jeffreypriebe Mar 18 '15 at 13:42
up vote 2 down vote accepted

I had a similar problem in the past. It sounds like the USB/SATA enclosure doesn't support the larger drive. For me, it was the large sector size... it was a pain. The weird part is, as you show, it works, but not the way you'd expect or like.

What's the make/model of the enclosure/USB-SATA adapter?

share|improve this answer
Sounds like a plausible theory. I think it is this: (can't be 100% sure of the model since the case doesn't show the model number). Current HDD is a Western Digital Green 2.5 TB - it was previously a WD Green 2 TB which was working fine in this same enclosure connected to the same router. – jeffreypriebe Mar 3 '12 at 19:13
Any idea what alternate sector sizes to look at. That is one step beyond my hardware knowledge. – jeffreypriebe Mar 3 '12 at 19:16
It's not clear if it supports 4k sector sizes. hmm. And the WD 2TB came in both 512 and 4k sizes. You can't configure the sector size, it's built into the disk. I'm not sure this is the issue though.... your disk is reporting slightly less than 1/8 the number of sectors. The numbers don't add up. Attached via SATA and USB, compare the output from a cmd prompt of c:\> wmic DISKDRIVE get bytespersector, caption That should show you the bytes per sector in each configuration. – mgjk Mar 3 '12 at 20:19
wmic DISK... shows 512 either way. Looks like this is WD's "512 emulation" at play? – jeffreypriebe Mar 3 '12 at 21:59
My old 2TB drive was older, so it seems very plausible it was truly 512. – jeffreypriebe Mar 3 '12 at 22:01

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.