Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Brand new machine that was working fine then randomly it changed the theme when I booted into a sort of "basic" theme (white task bar, no see through windows etc)

I've done and attempted many fixes and I still don't understand why it doesn't work. I've tried these two solutions:

"How to enable Windows 7 Aero Theme"

and

"Windows 7 Aero Themes Greyed out"

These solutions included registy changes, stopping/starting services, and force starting the aero theme. The closest I got seems to be when I went into:

Control panel (category view) > Find and fix problems (System and Security) > Display Aero Desktop Effects

I follow through the wizard and let it do its thing and then I get an error window that pops up: Personalization - "This theme can't be applied to the desktop. Try clicking a diffrent theme."

That's what I get from the wizard. What can I do? My drivers are all up to date, there are no viruses on the computer, directx is installed and updated, and the registry is all correct.

EDIT: When I boot the computer, I get a notification stating that windows failed to communicate with the windows desktop services.

share|improve this question
1  
Have you checked Device Manager to ensure your graphics adapter (drivers) are functioning correctly? How about a System Restore to a point before the trouble arose? –  Ƭᴇcʜιᴇ007 Mar 3 '12 at 20:10
    
Done the system restore and all drivers are working well. No fix. I get an error when I boot the pc, which I just edited into my post. –  Robolisk Mar 3 '12 at 20:27
add comment

9 Answers 9

Please try this to see if it fixes your problem:

  1. Go to your control panel and click on Performance Information and Tools.
  2. When the window pops up, look at the very bottom of the Performance Information and Tools window, in the right-hand side, for a link that says Re-run the assessment and Click on that link
  3. Windows will run through a series of test that will cause your display to flicker and flash but that is normal for that assessment test.

Good Luck!

share|improve this answer
add comment

I fixed this on my PC based on the answer by @cpufox.

I restarted the Themes service. It was started already, but restarting it fixed immediately. I didn't even have to go back in to the "Personalize" dialog to apply a theme.

Also, my Themes service was set to manual startup. I set this to Auto just in case.

share|improve this answer
3  
This worked for me, the wife complained that her lappy was missing the transparency... the baby had been hammering the keys, not sure what he'd done (maybe task managered something!), but all the themes were greyed out and I was scratching my head for a bit. A restart of the Themes service fixed it! –  Charleh Oct 12 '12 at 18:47
add comment

You can try the Microsoft Fix It tool. It will attempt to automatically diagnose and fix Aero problems such as:

  • A program you are running does not display the Aero effects
  • Some Aero effects such as transparency are not displayed
  • Identify if your video card doesn’t support the Aero required settings, color depth, or does not have sufficient memory to support some Aero effects
  • Identify if the required Desktop services, themes and indexes are running or disabled in order to display Aero effects
  • Identify if the current power settings do not support Aero desktop effects such as running on battery power
  • Windows borders are not displaying Aero transparency
share|improve this answer
1  
at iglvx, it gave you something to do. –  Moab Mar 4 '12 at 4:06
add comment

Double check the Windows 7 "Themes" Service is running.

Some folks, including me, followed a performance tweak and were stuck with the Windows 7 toolbar being a white (Windows Classic). Altering the theme did not correct this. It turned out the Themes service was not automatic.

If you have this problem, where Desktop (right-click) "Personalize" "Windows Color" showing only as Windows Classic).

Run "services.msc", ensure the "Themes" service is Automatic (and Started). That is the Windows 7 default mode for this Service.

Then you can then select any Windows Aero theme and it will provide the toolbar transparency again

Here's the interesting thing, I don't remember having altered the Themes service. My fault for doing this, but I had followed a tip, which I believe caused the issue. If you Right-click on Computer, Properties, left margin Advanced system settings, then Settings button in Performance section. On Visual Effects tab, Adjust for Best performance, you may end up with this issue once you Log Off or Restart. [ I don't recommend that option, or playing too much with de-selecting all but a few of the Custom options.

Later, I realized I wanted my default Windows 7 Toolbar look back! Aero troubleshooting and a Microsoft FixIt attempt did not find the problem. I went back to check ALL default Windows 7 Services and found the Themes service had been set away from Automatic. Hopefully, my learning the hard way may help you avoid going to far in this same way.

share|improve this answer
add comment

If your video card does not support Aero, Then you are stuck with the ugly blue/grey taskbar.. But there is a work around, you just need a program called TuneUp utilities and you will be able to change the taskbar to different colors....

share|improve this answer
add comment

Go click on the bottom left where the "start" symbol is for Windows 7. Then search "Services" click it then scroll down and find "Themes" then somehow set it too automatic if it is already right click it then go to all tasks, stop the service then to start it again right click, all tasks, then Start service.

share|improve this answer
add comment

I have similar problem, and this is the way I solve the problem:

  1. Run MSCONFIG
  2. At service tab, enable all services (mine, shows that something disable all services)
  3. Restart
share|improve this answer
add comment

Try this: Go to >Control Panel >Device Manager >Display Adapter. I had a Mirror Driver listed (I've been running UltraVNC). I uninstalled (right click on the mirror driver, left click on uninstall). Just leave there your graphics card > (e.g. mine, ATI Radeon HD 5700 Series). Then re-booted. I got my Aero back! :D

share|improve this answer
    
For me, the LogMeIn Mirror Driver was the culprit. I uninstalled that, and also LogMeIn (which may not have been necessary to solve this), rebooted, and now the problem is fixed. I'm not sure whether I'd been running Aero okay before; under Personalization, the "custom" color option brought up the retro XP-style color scheme modifier. After this fix, it brings up the newer one replete with the transparency options--I suppose that must mean Aero. Maybe there's a setting in LogMeIn that would have fixed this? –  r_alex_hall Sep 20 '13 at 23:06
add comment

i had the same problem, and i figured it out.

  1. Go to Control Panel and switch the view to Large icons.
  2. Go to Troubleshooting.
  3. Go to the bottom and click "Troubleshoot themes" (or at least something like that).
  4. It should take around 2 minutes and VOILA!!! It will reload and it will be back to normal.
share|improve this answer
2  
Can you clarify step 1? Where exactly is this "themes"? Do you mean the Personalization control panel? I don't see anything there about troubleshooting themes. –  Indrek Oct 4 '12 at 9:22
add comment

protected by Community Mar 21 '13 at 17:19

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.