Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to enable Firefox's "Browse by Name" feature, which lets you type a random string into the location bar and automatically have it searched using the search provider of your choice. This is what I did:

  1. Set keyword.enabled to true in about:config
  2. Set keyword.URL to http://www.google.com/search?btnI=I%27m+Feeling+Lucky&ie=UTF-8&oe=UTF-8&q=, which is used for Google's "I'm Feeling Lucky" feature, as described here.

But if I type google into the location bar and hit Enter, I get redirected to http://google/, a blank page which obviously isn't the site I want.

If I see what DNS info google gives using dig, I get the following output:

; <<>> DiG 9.8.1 <<>> google
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 63911
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;google.                IN  A

;; Query time: 62 msec
;; SERVER: 192.168.1.1#53(192.168.1.1)
;; WHEN: Sat Mar  3 16:06:03 2012
;; MSG SIZE  rcvd: 24

So it seems to be properly getting the NXDOMAIN result to a DNS lookup of google (I'm using OpenDNS as my DNS provider, so it was important to make sure of that). But I'm still not getting to http://www.google.com/ when I enter google in the location bar, like I should.

share|improve this question
    
What OS are you on? If Linux, what does getent hosts google return? –  grawity Mar 3 '12 at 22:29
add comment

3 Answers

DNS is (probably) not the problem. Either keyword.url is not in effect (despite the setting) or Firefox thinks that "google" is a valid URL.

Try this: change keyword.enabled to false, restart Firefox, change it back to true and restart. This worked for me.

share|improve this answer
add comment

Your Firefox parameters (Keyword.enabled and Keyword.url) are correct.

Btw: we don't have your Firefox version and Operationg System ...

1) Check in the Firefox Safe Mode

Press shift key and click on the Ff icon [Detailled info: http://kb.mozillazine.org/Safe_Mode ]

If the problem disappear in this mode the "culprit" is an add-on or plugin. At this stage of troubleshooting you have to find which one. First update all add-on and plugins. Then disable one plugin at the time, restart Firefox and check again with the keyword...

Check in detailled your Ff parameters by typing about:support in the address bar.

2) Check with another profile [Detailled info: http://kb.mozillazine.org/Command_line_arguments ]

Set the two parameters we're talking about in this new profile. If the problem disappear, somethings wrong in the other profile but not an add-on or plugin. At this stage you may try to find the problem's source but the easiest way is to recover your important data from the old profile to the new one. Check for "Recovering important data from an old profile" in the Firefox help pages.

3) Check the HOSTS file

Backup the HOSTS file and use a minimal one instead with only these lines:

127.0.0.1  localhost loopback
::1        localhost

If the problem disappear at this stage you know where the problem is...

4) Check an alternate DNS server. Try temporarely Public Google DNS 8.8.8.8 and 8.8.4.4 for example...

Hope this help. Let us know.

share|improve this answer
    
The problem disappeared when I tethered with my phone, so it's clearly something with my network, and not my computer. I'm using pfSense as my router, and it is presumably caching DNS requests. The DNS servers it's using are the OpenDNS ones, followed by the Google ones. I've set up OpenDNS so that it will send me NXDOMAIN for invalid DNS requests. –  srunni Mar 10 '12 at 21:17
    
Strange... May be a parameter in the dynamic DNS od Pfsense. More help from the PFSense support about this issue: forum.pfsense.org –  climenole Mar 11 '12 at 4:08
add comment

I've found that Firefox only searches from the address bar if what is entered cannot be interpreted as a valid URI. A single word usually can be.

As a workaround I've been using InstantFox. It works as expected. It's generally used with one (or more) letter at the start of your search to specify the search engine, though the standard search without shortcuts option will search when any phrase is entered, and search suggestions can be enabled.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.