Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm a beginner Linuxer. Just bought Acer Revo netbook which came preinstalled with Linpus - which doesn't come with the standard Linux package manager and I'm unable to download and install any apps. I want to get rid of Linpus and install Linux Mint. I've made a bootable USB to do this using UNetbootin but it's not working properly. On opening UNetbootin it tells me I need the 7z app to do the install, but it allows me to continue. On reboot I select USB and it brings up one choice only, Default, and a 10 second timer which gets down to 0 and starts counting down again. No way out. If I hit Tab then it shows a couple lines of 'black box' code with last word: persistent - which I've been told is good. I've downloaded p7zip-full via browser but am unable to install it. I've followed instructs on this page http://www.linuxnewbieguide.org/content/chapter-9-how-do-i-install-software-linux but it always returns 'couldn't find package..'

Also I'm a bit confused as to what exactly Linpus is, or rather, what base Linux system it uses. I can't find it now, but I think I read somewhere that it's based on Fedora? Does it make a difference to the file suffix of any apps I try to download? I've been going for the .deb ones.

Any suggestions how to proceed? My brother was trying to help me over the phone earlier but he's spending the weekend with his girlfriend after a month away, and I really don't want to disturb him any more tonight :-( Thanks in advance for any help.

  • If I could just find out how to download and install apps on Linpus to get me through the weekend I'd be a happy bunny! Mint can wait til Monday :)

**MONDAY, SITUATION RESOLVED, UPDATE A horribly easy solution in the end - we used Windows to create the bootable USB via Unetbootin and now happy bunnies are everywhere! Thank you.

share|improve this question
    
Just to note, I tried linpus with a system a client brought in, and ended up swapping OSes. It seemed to be fedora 5 based - fedora uses RPMs –  Journeyman Geek Mar 4 '12 at 3:29
    
Linpus basically is holding me prisoner. Their update server is still offline, I'm going round in circles unable to even update Firefox from version 3. Can't install Chrome, or anything :-( –  Caroline Mar 4 '12 at 17:41
    
I am afraid, its exactly the same experience i had with linpus when i was working on the client's system, and i'm reasonably experienced. I do have other systems to create the install media on, which is much less painful –  Journeyman Geek Mar 4 '12 at 23:57

1 Answer 1

I found the answer here in the quick start and installation guide.

You can launch the Linpus online update service (see Figure 3-11) from under System Tools > Live Updates > Add/Remove. The icons of those newly added applications will be displayed on the “Applications” panel. After you select the item and click the Install button, you can start to install new applications

however if you which to give mint a try you could use this tool which im am using when i need usb bootdisks. However this needs python, so you have to make sure you have installed the python interpreter.

First unpack the tar.gz archive:

tar xvfz abock-image-usb-stick-f3b1002.tar.gz 

and change in the new folder:

cd abock-image-usb-stick-f3b1002/

Using the tool is very easy. Once you have figured out which device is your usbdisk by typing:

sudo fdisk -l

Assuming /dev/sdb is your usb stick and mint.iso is in ~/Downloads just type from the directory you have created when unpacking the tar.gz file:

sudo ./image-usb-stick -d /dev/sdb ~/Downloads/mint.iso

Hope this helped.

share|improve this answer
    
Thank you for your response! I've got Python updated and the abock file downloaded, but am unable to unpack the tar.gz archive as per your instructs due to invalid syntax (pointing to the xvf): 'code'>>> tar xvf abock-image-usb-stick-f3b1002.tar.gz File "<stdin>", line 1 tar xvf abock-image-usb-stick-f3b1002.tar.gz 'code' - and the filename is exactly the same as above. –  Caroline Mar 4 '12 at 1:45
    
oh i am very sorry its "tar xvfz" you can leave the v but not the z ;) i will correct that. –  l1zard Mar 4 '12 at 11:41
    
Thank you, but unfortunately now I get a different error, says: Cannot open: No such file or directory. The file was on desktop, then I tried again after moving it to Downloads. Is there a specific location it needs to be in or is the error due to something else? TIA –  Caroline Mar 4 '12 at 16:59
    
You have to open a Shell/Terminal/Konsole (however you call it) and use cd to change in the directory where you have downloaded the file. If this is for example Downloads you can use "cd ~/Downloads". The ~ expands to your home directory so that you also could type "cd /home/<user>/Downloads", where user is your user name. I Suggest you to begin reading some documentation. greetings. –  l1zard Mar 4 '12 at 17:41
    
Sorry to be such a buffoon, but have another problem now. 'code'# sudo ./image-usb-stick -d /dev/sdb1 ~/Desktop/mint.iso ./image-usb-stick:250: Warning: 'with' will become a reserved keyword in Python 2.6 File "./image-usb-stick", line 250 with open ('/sys/class/block/%s/size' % \ ^ SyntaxError: invalid syntax 'code' - am not sure how to continue :( In the meantime am going to try downloading 7zip in tar.gz format and go back to original plan. Very much appreciate your help, thank you! –  Caroline Mar 4 '12 at 19:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.