Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I was trying to put the Windows 8 Consumer Preview onto a thumb drive, when I was asked if I was OK with wiping it (I said yes I as it was blank).

I had to sleep my computer during the wiping, and now I can't do anything with my dive.

When I put it into my computer:

Asked to reformat

When I click format disk:

Unknown capacity

In short, the disk never reformats (I get an error message letting me know that Windows was unable to format the drive). Whats going on, and how do I fix it?

share|improve this question
What if you uncheck "Quick Format"? That will do a full format and might clear up the problem. – Jim G. Mar 4 '12 at 0:40
"Windows was unable to complete the format" – wizlog Mar 4 '12 at 0:46
See if this utility cures that – Moab Mar 4 '12 at 0:48
Post that as an answer, and explain it. – wizlog Mar 4 '12 at 14:24
up vote 3 down vote accepted

Try this:

  1. Start > Run
  2. Type: diskpart
  3. Execute: list disk
  4. Execute: select disk # (# is the number of your USB)
  5. Execute: clean
  6. Execute: create partition primary
  7. Execute: format recommended quick
share|improve this answer

If you have a Linux live media, use it to reformat the USB flash drive using GParted or other similar software.

Or you could try formatting your drive through cmd. Here is a nice tutorial to do so.

A summary of the steps you might use, based on the eHow article linked above:

  • Open a command shell and launch diskpart.
  • Type "list disk".
  • Find the disk number for the one you want to format and type "select disk x" (replace x with disk number - e.g., "select disk 5").
  • Type "clean". This will remove all formatting and partition information from the thumb drive.
  • Type "create partition primary".
  • Type "exit" to close diskpart.

At this point, you can probably try again the usual methods of formatting - either using the format command in the shell or using Windows Explorer.

share|improve this answer

If there was an incomplete formatting of the drive, you may need to reformat using Windows disk management. In Windows 7, open Disk Management: Start Button > Control Panel > System & Security > Administrative Tools > Computer Management > Storage > Disk Management Identify your USB drive in the list of drives (if it does not display, be sure it fully plugged in, turned on, etc.) Right click it, and select "Format" Click "Yes" (will wipe drive), then select file type (NTFS or FAT32), and click OK No dialog will display, instead the status of the drive in the list will be "Formatting", once done it will change to "Healthy" or similar. Now assign it a drive letter: right click, "Assign Drive Letter", choose preferred letter (not is use) and click ok. Should be good now!

share|improve this answer

I ran into this same exact problem. The answers above were of no help, because they were not possible to perform.

  • DISKPART list disk: shows the drive as 0 B with a status of No Media.
  • DISKPART clean: returns "There is no media in the device."
  • DISKPART create partition primary: returns "No usable free extent could be found…"
  • Formatting via the dialog from the right-click menu returns "Windows was unable to format the drive."
  • At one point, Windows Explorer wouldn't show the drive or says it is unrecognized.
  • Device Manager's Disk Management shows the drive as an empty box.
  • At one point, Disk Management showed the drive as Unallocated, and any attempts to format it generate an error: There is no media in the device.

What finally worked for me was the classic IT advice: Turn it off and back on.

Specifically, rebooting the computer with the USB drive plugged in (I'd previously been plugging it in after rebooting). This worked on two separate USB drives that were encountering the same problem (one of them was already in this state upon arrival, the other got this way after a formatting operation was interrupted). The computer I was using was running Windows 7 Enterprise 64-bit. Hope this helps someone.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.