Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Possible Duplicate:
How can I make a USB flash drive appear/not appear as a CD drive?

I have a 2GB flash drive that was a freebie giveaway at some HP event. The drive works fine, except that the HP guys formatted it in such a way that one portion is 17.2MB of CDFS, and the rest is free fore me to use. It's obviously not a CD drive, but their formatting it as such allows them to ensure that their propagandish applications and "buy our products"s not be deleted.

Obviously, I want to delete them.

Windows seems to be pretty much impassive to all my attempts. I've tried using format F:, but the command prompt refuses to format because the "volume is write protected." Windows Explorer seems to actually think that it's a CD drive, as it has a context menu entry for "Close Tray" (which of course does nothing. Windows's "Disk Management" service won't let me format it, either.

Linux's (Mint, specifically, though I don't suppose that it matters) parted and gparted only recognize the user-writable portion of the disk (the non-CDFS portion). They allow me to manipulate it - I've tried creating a new partition table - but it doesn't affect the CDFS portion. Linux's nautilus (roughly equivalent to Windows Explorer, in case you don't know) does not recognize the offending partition.

In case anyone happens to have this exact drive and they figured it out: The drive has a lightly brushed aluminum chassis with a cut for a keychain, etc. on one end. The internal workings of the drive are contained by what appears to be either aluminum or steel, and is covered with leather, in which the HP logo is engraved. A stitched leather strap with a brushed aluminum cap is attached with a ~1/4" flathead screw.

As mentioned before, the drive is otherwise in perfect working order.

Any help/ideas/suggestions?



share|improve this question

marked as duplicate by Synetech, Ƭᴇcʜιᴇ007, Sathya Mar 27 '12 at 7:38

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

up vote 1 down vote accepted

More likely, the drive is not actually "partitioned", but rather presents itself as two devices -- one USB harddrive and one USB CD. I don't know about your particular thumbdrive, of course, but I have seen quite a number of thumbdrives that work like that. I think the main reason the manufacturers do that is because many Windows versions always autorun content on CDs by default, unlike the harddrives which Windows asks about instead.

Since that is built-in to the drive's very firmware, you cannot change it with a partition editor or anything like that. However, there are some thumbdrives that people out there have hacked and written tools to overwrite its firmware with one that lacks the CD device. Try googling for your particular model and see if you can find something.

share|improve this answer
Yeah, this seems to be the case. Unfortunately, the drive that I have doesn't have any particular "model" (I think HP made them just for freebies/whatever), so I'm not sure what to search. Thanks, though, for telling me. – wchargin Mar 4 '12 at 8:27
@WChargin: More than likely this is done in a modifiable way. HP probably doesn't manufacture pendrives and simply sourced empty U3-type drives from another manufacturer. It's unlikely that the write-protected files have to be put in at the factory, as most of these drives are designed for consumer use. You might be able to figure out the model using ChipGenius or checking out this page. – Lèse majesté Mar 4 '12 at 11:24

I wonder if its a U3 drive - on which case, you can either use sandisk's removal tool or U3tool to remove it.

share|improve this answer

I would try changing the partition id in diskpart - if it can see the partition.

  1. Open command prompt
  2. Type diskpart
  3. Type list disk
  4. Type select disk=#, where # is the disk number of your 2GB flash drive from the previous step.
  5. Type list partition
  6. If you can see your CDFS partition, type select partition=#, where # is the partition number of your CDFS partition from the previous step.
  7. Type set id=0b override, which should set it to a FAT32 partition id. If this worked, you can now reformat normally. id=07 can also be tried (NTFS).

Reading some forums, you can also try Kill Disk, especially the bootable version so you don't have an OS locking it. Just make sure you don't wipe your hard drive!

There's also the possibility it's locked by the firmware of the flash drive, in which case there isn't much you can do, maybe buy a new one. 2GB flash drives are rather cheap now.

share|improve this answer
Thanks for the idea, but, unfortunately, it only shows one partition. I'll try Kill Disk now. – wchargin Mar 4 '12 at 8:06
Unfortunately, Kill Disk didn't work. Thanks for the idea, anyway! – wchargin Mar 4 '12 at 8:24

Not the answer you're looking for? Browse other questions tagged or ask your own question.